summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-16 04:12:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-16 05:01:53 +0100
commit653e4f1a3f178f7f66edaadd9b9eeeb72dc47836 (patch)
treebf7e0a3baed08442df1ca6ae067dc9ead24064dc /dev-python/mido/mido-1.3.2.ebuild
parentdev-python/dask: Bump to 2023.12.1 (diff)
downloadgentoo-653e4f1a3f178f7f66edaadd9b9eeeb72dc47836.tar.gz
gentoo-653e4f1a3f178f7f66edaadd9b9eeeb72dc47836.tar.bz2
gentoo-653e4f1a3f178f7f66edaadd9b9eeeb72dc47836.zip
dev-python/mido: Bump to 1.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mido/mido-1.3.2.ebuild')
-rw-r--r--dev-python/mido/mido-1.3.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/mido/mido-1.3.2.ebuild b/dev-python/mido/mido-1.3.2.ebuild
new file mode 100644
index 000000000000..fc7fb16de40f
--- /dev/null
+++ b/dev-python/mido/mido-1.3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MIDI Objects, a library for working with MIDI messages and ports"
+HOMEPAGE="
+ https://pypi.org/project/mido/
+ https://github.com/mido/mido
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+portmidi rtmidi"
+
+RDEPEND="
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ portmidi? ( media-libs/portmidi )
+ rtmidi? ( dev-python/python-rtmidi[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # performance test
+ tests/midifiles/test_tracks.py::test_merge_large_midifile
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}