summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-10 20:45:00 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-12 00:39:42 +0200
commit7c028337720868ab2c40f38ceeb36667e44f3a80 (patch)
tree1cec03b5d79a29880c2749a41ac27b44955e2b37 /dev-python/manuel
parentx11-base/xorg-server: Version bump to 1.20.1 (diff)
downloadgentoo-7c028337720868ab2c40f38ceeb36667e44f3a80.tar.gz
gentoo-7c028337720868ab2c40f38ceeb36667e44f3a80.tar.bz2
gentoo-7c028337720868ab2c40f38ceeb36667e44f3a80.zip
dev-python/manuel: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/manuel')
-rw-r--r--dev-python/manuel/Manifest1
-rw-r--r--dev-python/manuel/manuel-1.9.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/manuel/Manifest b/dev-python/manuel/Manifest
index 146027d12ade..5e2344a9aad0 100644
--- a/dev-python/manuel/Manifest
+++ b/dev-python/manuel/Manifest
@@ -1 +1,2 @@
DIST manuel-1.8.0.tar.gz 207600 BLAKE2B f7bad36491d49254c7aea17550cbd4fa00b6c3c122061586785da4bddc514f51a2d5a8df3b048fe78c7b01036ca903330ea614c998fdd04d1e8cca002930c962 SHA512 8099df44cfd28c8ac6256f346bf8cd36091893a38d3c297099866b1a5db97286b9c9e69f3f12054d7eee9ae3985ca0a003d7b2cc082d28d59850bbcad6b57c57
+DIST manuel-1.9.0.tar.gz 39640 BLAKE2B 1b699b92816297fee13a65ed2c4fc9ee3683f8e47e7fbf06178c97167ae29cabcedc48edec48b053f725889b39111b3634f0305ac651b5674292d046434fd134 SHA512 519b0fd1bd7ef3414dec69f721a6f1265603d28e3b61681acf46e9fba6fdc66efb6c0a82d814af8348bb7c07c3c4c299ae94ea7d6415436592ac37fccaacf18a
diff --git a/dev-python/manuel/manuel-1.9.0.ebuild b/dev-python/manuel/manuel-1.9.0.ebuild
new file mode 100644
index 000000000000..516294c9b32d
--- /dev/null
+++ b/dev-python/manuel/manuel-1.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Manuel lets you build tested documentation"
+HOMEPAGE="https://github.com/benji-york/manuel/ https://pypi.org/project/manuel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Required to run tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+#DOCS=( CHANGES.rst )
+
+#PATCHES=( "${FILESDIR}"/${P}-rm_zope_test.patch )
+
+#python_test() {
+# PYTHONPATH=src/:${PYTHONPATH} esetup.py test
+#}