summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-15 08:13:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-15 10:23:30 +0200
commitf71792379d4abcf257f43c825fc316dd6d628ab6 (patch)
tree9bd005f106723a825018f3fee36c3c262c62c58f /dev-python/loky
parentdev-python/xcffib: Bump to 1.3.0 (diff)
downloadgentoo-f71792379d4abcf257f43c825fc316dd6d628ab6.tar.gz
gentoo-f71792379d4abcf257f43c825fc316dd6d628ab6.tar.bz2
gentoo-f71792379d4abcf257f43c825fc316dd6d628ab6.zip
dev-python/loky: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/loky')
-rw-r--r--dev-python/loky/Manifest1
-rw-r--r--dev-python/loky/loky-3.4.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index 11c300fae655..589fef5e643e 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1 +1,2 @@
DIST loky-3.3.0.gh.tar.gz 141130 BLAKE2B 35560dca81cf41e03b24c8be6e70952c19b88fc9794cb13d7c910ac67ec4554555233026a215c6f147dc1354ad11bc14117b4eb6455ba758b79ea6650dc01f62 SHA512 120f771c75fe8691a198c93a91bf683af3d32c1bcaf2fa3e9c439d16546bff9feb6ce203667bd6c4e06ac326500b7bd117948e4deea6f53b04682af1f8d65734
+DIST loky-3.4.0.gh.tar.gz 143864 BLAKE2B bebfa2c934e4645c5cd1a4c62792bccd9b5a4ef3c9a104809b57f35ba3318596717bf82714c1b7583675bdc504dc0a2054a88009d964a900176d353a54add52c SHA512 d8113f6f6c173c208b90c29bc4a296d7844f7010cfcabbd8d55106b8e93f256b2debb86aa993a33c41f40fcdd4f00c1e1e010dbe4a184b138da357652315657c
diff --git a/dev-python/loky/loky-3.4.0.ebuild b/dev-python/loky/loky-3.4.0.ebuild
new file mode 100644
index 000000000000..0ab8fd36be97
--- /dev/null
+++ b/dev-python/loky/loky-3.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Robust and reusable Executor for joblib"
+HOMEPAGE="
+ https://github.com/joblib/loky/
+ https://pypi.org/project/loky/
+"
+SRC_URI="
+ https://github.com/joblib/loky/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ EPYTEST_DESELECT=(
+ # docker, seriously?
+ tests/test_loky_module.py::test_cpu_count_cfs_limit
+ # hangs, and even pytest-timeout does not help
+ tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
+ tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
+ )
+
+ # high memory test needs a lot of memory + is broken on 32-bit platforms
+ epytest --skip-high-memory
+}