summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-21 13:29:29 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 13:34:53 +0100
commit964cea00ca5cf5ae4412dc70591b1ebf02395375 (patch)
tree9308349f7536c84d1f2de5e7fd2d4b8150e4b441 /dev-python/loguru
parentdev-python/environs: Enable py3.11 (diff)
downloadgentoo-964cea00ca5cf5ae4412dc70591b1ebf02395375.tar.gz
gentoo-964cea00ca5cf5ae4412dc70591b1ebf02395375.tar.bz2
gentoo-964cea00ca5cf5ae4412dc70591b1ebf02395375.zip
dev-python/loguru: PEP517, modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/loguru')
-rw-r--r--dev-python/loguru/Manifest1
-rw-r--r--dev-python/loguru/loguru-0.6.0-r1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/loguru/Manifest b/dev-python/loguru/Manifest
index 39d14b070605..90c60f6e77ba 100644
--- a/dev-python/loguru/Manifest
+++ b/dev-python/loguru/Manifest
@@ -1 +1,2 @@
+DIST loguru-0.6.0.gh.tar.gz 417660 BLAKE2B a7b7d95ffcf652769503db3423768ff85a4fa4898f0e2b155d96ce0c42fa7f24255f9dc49ba62e8a4f19bb3b7cc8b374580fe0965c9683b14d9bcea9866e71a5 SHA512 6ca7087cde3b4ce11255e31af988e5e118a7ebfbb338b97ebd6e7e4af716f0301c0180a59b18c879fd799c25802b428411b868290b7593212f06d70bcbd6a9ca
DIST loguru-0.6.0.tar.gz 417660 BLAKE2B a7b7d95ffcf652769503db3423768ff85a4fa4898f0e2b155d96ce0c42fa7f24255f9dc49ba62e8a4f19bb3b7cc8b374580fe0965c9683b14d9bcea9866e71a5 SHA512 6ca7087cde3b4ce11255e31af988e5e118a7ebfbb338b97ebd6e7e4af716f0301c0180a59b18c879fd799c25802b428411b868290b7593212f06d70bcbd6a9ca
diff --git a/dev-python/loguru/loguru-0.6.0-r1.ebuild b/dev-python/loguru/loguru-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..6c59eba2c805
--- /dev/null
+++ b/dev-python/loguru/loguru-0.6.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging made (stupidly) simple"
+HOMEPAGE="
+ https://github.com/Delgan/loguru/
+ https://pypi.org/project/loguru/
+"
+SRC_URI="
+ https://github.com/Delgan/loguru/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0.6.0-typos.patch"
+)
+
+# filesystem buffering tests may fail
+# on tmpfs with 64k PAGESZ, but pass fine on ext4
+distutils_enable_tests pytest