summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-24 21:37:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-24 22:05:09 +0200
commit3da0b79a02cd9a6fdac06aa37419b7e05767e26c (patch)
tree669640194d291fa5069e97cc7fd09cabd54245af /dev-python/line_profiler
parentdev-python/line_profiler: Remove old (diff)
downloadgentoo-3da0b79a02cd9a6fdac06aa37419b7e05767e26c.tar.gz
gentoo-3da0b79a02cd9a6fdac06aa37419b7e05767e26c.tar.bz2
gentoo-3da0b79a02cd9a6fdac06aa37419b7e05767e26c.zip
dev-python/line_profiler: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest1
-rw-r--r--dev-python/line_profiler/line_profiler-3.3.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index d46f090d489f..f18e60ea4a85 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1 +1,2 @@
DIST line_profiler-3.3.0.gh.tar.gz 52791 BLAKE2B e3499f5274045d158620fa890df6e725a99c3df019bb4515434213d2c60d52d400d7a7dfce64b153422722ea388f73318818485c9747e6eace2d81c457f93a7f SHA512 37680c55a551c73aed7a3ee2333c523f0617e01cda6db98060f15fe36990c8c8bc08bd5848e569f269bf11590776290ee0980046cce745df8e54268d7991559b
+DIST line_profiler-3.3.1.gh.tar.gz 56700 BLAKE2B 030c0fc742a6773ebb55a54a3c21d3d5e5d6d5d258a2c3cd2071ff93917411b65e100bfc6549d9c60d9a7c361c53b291d8b81538acaf5b83665c04129d25bc02 SHA512 8a3704a6df2abe71283cb2da23b738932c6f4b42aedcdefda0d318fd4b894d56831a855c4be4430657308530a04d1e96b0e15a60edca06621bdd5370c0bf9911
diff --git a/dev-python/line_profiler/line_profiler-3.3.1.ebuild b/dev-python/line_profiler/line_profiler-3.3.1.ebuild
new file mode 100644
index 000000000000..5bbfce251694
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-3.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+# force it to match scikit-build
+CMAKE_MAKEFILE_GENERATOR=ninja
+
+inherit cmake distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="https://github.com/pyutils/line_profiler/"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+# technically, the package claims to support non-scikit-build build
+# but it's clearly unmaintained and broken at the moment
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/scikit-build[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd tests || die
+ epytest
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}