summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/libwnck-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/libwnck-python')
-rw-r--r--dev-python/libwnck-python/Manifest1
-rw-r--r--dev-python/libwnck-python/files/libwnck-python-2.30.2-flagsfix.patch30
-rw-r--r--dev-python/libwnck-python/libwnck-python-2.32.0-r1.ebuild29
-rw-r--r--dev-python/libwnck-python/metadata.xml5
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/libwnck-python/Manifest b/dev-python/libwnck-python/Manifest
new file mode 100644
index 000000000000..b3c5fb4b1ca1
--- /dev/null
+++ b/dev-python/libwnck-python/Manifest
@@ -0,0 +1 @@
+DIST gnome-python-desktop-2.32.0.tar.bz2 621277 SHA256 09dbd580bf3b0ef60f91b090eafe6d08ddcc50a609e2b425a7f8eca46d4e0ee9 SHA512 51beefd21fa3aa6242ba4c66e57d940372fbf4a84ffe34063339f6e7e7c22e76d281b25d5f113de3780a0dbf733c7e07142f05a285056cda26736323b4185d18 WHIRLPOOL 5713353291a34e0a03152ad76c46391e3ab246efc17b63193fc0b26b02176eb78ce134c8d0cabcb3480bd2dbb3446b7b6b301cffbfac3ce915e21a974947e37e
diff --git a/dev-python/libwnck-python/files/libwnck-python-2.30.2-flagsfix.patch b/dev-python/libwnck-python/files/libwnck-python-2.30.2-flagsfix.patch
new file mode 100644
index 000000000000..0be84c96b533
--- /dev/null
+++ b/dev-python/libwnck-python/files/libwnck-python-2.30.2-flagsfix.patch
@@ -0,0 +1,30 @@
+diff -up gnome-python-desktop-2.30.0/wnck/wnck.defs.flagsfix gnome-python-desktop-2.30.0/wnck/wnck.defs
+--- gnome-python-desktop-2.30.0/wnck/wnck.defs.flagsfix 2010-04-20 11:27:20.119491538 -0400
++++ gnome-python-desktop-2.30.0/wnck/wnck.defs 2010-04-20 11:28:34.715491536 -0400
+@@ -100,7 +100,7 @@
+ )
+ )
+
+-(define-enum WindowState
++(define-flags WindowState
+ (in-module "Wnck")
+ (c-name "WnckWindowState")
+ (gtype-id "WNCK_TYPE_WINDOW_STATE")
+@@ -121,7 +121,7 @@
+ )
+ )
+
+-(define-enum WindowActions
++(define-flags WindowActions
+ (in-module "Wnck")
+ (c-name "WnckWindowActions")
+ (gtype-id "WNCK_TYPE_WINDOW_ACTIONS")
+@@ -184,7 +184,7 @@
+ )
+ )
+
+-(define-enum WindowMoveResizeMask
++(define-flags WindowMoveResizeMask
+ (in-module "Wnck")
+ (c-name "WnckWindowMoveResizeMask")
+ (gtype-id "WNCK_TYPE_WINDOW_MOVE_RESIZE_MASK")
diff --git a/dev-python/libwnck-python/libwnck-python-2.32.0-r1.ebuild b/dev-python/libwnck-python/libwnck-python-2.32.0-r1.ebuild
new file mode 100644
index 000000000000..90d0ec27af95
--- /dev/null
+++ b/dev-python/libwnck-python/libwnck-python-2.32.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GNOME_ORG_MODULE="gnome-python-desktop"
+G_PY_BINDINGS="wnck"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome-python-common-r1 eutils
+
+DESCRIPTION="Python bindings for the libwnck library"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=x11-libs/libwnck-2.19.3:1
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}"
+
+EXAMPLES=( examples/wnck_example.py )
+
+src_prepare() {
+ # Fix three enum items that should be flags, upstream bug #616306
+ epatch "${FILESDIR}/${PN}-2.30.2-flagsfix.patch"
+ gnome-python-common-r1_src_prepare
+}
diff --git a/dev-python/libwnck-python/metadata.xml b/dev-python/libwnck-python/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/dev-python/libwnck-python/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>