summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 12:55:56 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 12:55:56 +0200
commiteef8388986035f6049e726397db97c753bed8e4b (patch)
treee661d9d03748f76c6b7c21da7489e245f15c0628 /dev-python/liblarch
parentdev-python/lesscpy: Enable py3.9 & py3.10 (diff)
downloadgentoo-eef8388986035f6049e726397db97c753bed8e4b.tar.gz
gentoo-eef8388986035f6049e726397db97c753bed8e4b.tar.bz2
gentoo-eef8388986035f6049e726397db97c753bed8e4b.zip
dev-python/liblarch: Enable py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/liblarch')
-rw-r--r--dev-python/liblarch/liblarch-3.0.1.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-python/liblarch/liblarch-3.0.1.ebuild b/dev-python/liblarch/liblarch-3.0.1.ebuild
index eebf15b1e445..7122e078145e 100644
--- a/dev-python/liblarch/liblarch-3.0.1.ebuild
+++ b/dev-python/liblarch/liblarch-3.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1 virtualx
@@ -14,18 +14,15 @@ SRC_URI="https://github.com/getting-things-gnome/liblarch/archive/v${PV}.tar.gz
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
DEPEND="
dev-python/pygobject:3[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
"
RDEPEND="${DEPEND}"
-BDEPEND="
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-python_test() {
- virtx nosetests -v || die "Tests fail with ${EPYTHON}"
+distutils_enable_tests nose
+
+src_test() {
+ virtx distutils-r1_src_test
}