summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 16:16:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 16:33:58 +0200
commita8e9dcdec23cef8712800471475cc8b6d7deb646 (patch)
tree50fd0b7fca00c760bca03938d890673b309c79ca /dev-python/lesscpy
parentsys-apps/portage: install tmpfiles.d to create /var/tmp/portage (diff)
downloadgentoo-a8e9dcdec23cef8712800471475cc8b6d7deb646.tar.gz
gentoo-a8e9dcdec23cef8712800471475cc8b6d7deb646.tar.bz2
gentoo-a8e9dcdec23cef8712800471475cc8b6d7deb646.zip
dev-python/lesscpy: Bump to 0.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lesscpy')
-rw-r--r--dev-python/lesscpy/Manifest1
-rw-r--r--dev-python/lesscpy/lesscpy-0.15.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/lesscpy/Manifest b/dev-python/lesscpy/Manifest
index 7041fba9bb05..9d2043d92fd4 100644
--- a/dev-python/lesscpy/Manifest
+++ b/dev-python/lesscpy/Manifest
@@ -1 +1,2 @@
DIST lesscpy-0.15.0.tar.gz 176879 BLAKE2B 942775e090d3fbc8af033163186d43650bf20967689459bedd87dba14063c199fa322a17310fde422e3d45370cc7fee3482ff2a388518c49b2b16fb40f241a69 SHA512 3e225dcd435b9fbf9b21ad7cae86612eee923946b0bafd502221a95df4df739bae8df62f33fe77a90ee8a1c12de05ba556b2d76a95b85c9d68d27ce6ae46a747
+DIST lesscpy-0.15.1.tar.gz 177240 BLAKE2B 3199c3daecb3703039d13be6a23619e2a0e590c2b8f5450cd526e3bdedb22f8f782291ba820a8e1dcd06bca6542fb91eacd9d20b7f1f05cff701038d45e8e3cb SHA512 3a88c14d1e47a28d5e427e9cd0e1c2553dd3fc937085c54975c3e2612d623673e0a2fe05d7bb60dcdeda0f352b1be0354595ba9fac38483e7ab0a21529036e65
diff --git a/dev-python/lesscpy/lesscpy-0.15.1.ebuild b/dev-python/lesscpy/lesscpy-0.15.1.ebuild
new file mode 100644
index 000000000000..b5200810f11f
--- /dev/null
+++ b/dev-python/lesscpy/lesscpy-0.15.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A compiler written in Python for the LESS language"
+HOMEPAGE="
+ https://github.com/lesscpy/lesscpy/
+ https://pypi.org/project/lesscpy/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest