summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-21 08:36:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 08:37:36 +0100
commit11625ecd2ffb3d2c582b7b88c0e7f6fe4eec3874 (patch)
tree053277c6cbda5b02c8314f3e00345a9b5e1b760f /dev-python/kafka-python
parentdev-python/kombu: Use pypi.eclass (diff)
downloadgentoo-11625ecd2ffb3d2c582b7b88c0e7f6fe4eec3874.tar.gz
gentoo-11625ecd2ffb3d2c582b7b88c0e7f6fe4eec3874.tar.bz2
gentoo-11625ecd2ffb3d2c582b7b88c0e7f6fe4eec3874.zip
dev-python/kafka-python: EAPI 8, modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kafka-python')
-rw-r--r--dev-python/kafka-python/Manifest1
-rw-r--r--dev-python/kafka-python/kafka-python-2.0.2-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/kafka-python/Manifest b/dev-python/kafka-python/Manifest
index f60037d646cb..3ce259cfeaab 100644
--- a/dev-python/kafka-python/Manifest
+++ b/dev-python/kafka-python/Manifest
@@ -1 +1,2 @@
+DIST kafka-python-2.0.2.gh.tar.gz 327238 BLAKE2B 9d8bdee1cedcc3c7c0bee9d900bb815552b29f50ec45b7db9d1052a26eb772c84d92648ccc0d498189fc44314f5c8c30529fa61cb983481f2e2480e009630f91 SHA512 e193a8fe5852d2134e854749115feba46a0b8ff748336989a27bf56acba1124dbb8a5d841670a67ee26eef030a686d931d03d329f978b2eef7904183e83d2594
DIST kafka-python-2.0.2.tar.gz 327238 BLAKE2B 9d8bdee1cedcc3c7c0bee9d900bb815552b29f50ec45b7db9d1052a26eb772c84d92648ccc0d498189fc44314f5c8c30529fa61cb983481f2e2480e009630f91 SHA512 e193a8fe5852d2134e854749115feba46a0b8ff748336989a27bf56acba1124dbb8a5d841670a67ee26eef030a686d931d03d329f978b2eef7904183e83d2594
diff --git a/dev-python/kafka-python/kafka-python-2.0.2-r1.ebuild b/dev-python/kafka-python/kafka-python-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..911f0ecfa1e6
--- /dev/null
+++ b/dev-python/kafka-python/kafka-python-2.0.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Kafka protocol support in Python"
+HOMEPAGE="
+ https://github.com/dpkp/kafka-python/
+ https://pypi.org/project/kafka-python/
+"
+SRC_URI="
+ https://github.com/dpkp/kafka-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/xxhash[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lz4[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ dev-python/python-snappy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Needs the unpackaged crc32c module
+ "test/record/test_util.py::test_crc32c[None]"
+ # Needs kafka server running
+ test/test_consumer_integration.py::test_kafka_consumer_offsets_for_time_old
+)
+
+pkg_postinst() {
+ optfeature "LZ4 compression/decompression support" dev-python/lz4
+ optfeature "Snappy compression support" dev-python/python-snappy
+ optfeature "ZSTD compression/decompression support" dev-python/zstandard
+}