summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-20 12:35:48 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-20 12:47:03 +0200
commit521758b16018b94bef8480a56a5f51d35a1f9700 (patch)
tree4ad418bccb1b8bc69999531795af0653e5a73f6a /dev-python/jupyterlab-lsp
parentdev-python/nbconvert: add 7.7.2 (diff)
downloadgentoo-521758b16018b94bef8480a56a5f51d35a1f9700.tar.gz
gentoo-521758b16018b94bef8480a56a5f51d35a1f9700.tar.bz2
gentoo-521758b16018b94bef8480a56a5f51d35a1f9700.zip
dev-python/jupyterlab-lsp: add 4.2.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest1
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-4.2.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 4fd8844edd15..83ebd89adc31 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab-lsp-4.0.1.tar.gz 869528 BLAKE2B 62df16ba8aef6c344324346501191776a0534ddf6b5acff4de477f8f7f8996f7ec78022bada4c16d582fdfb7f916fd70f6c9c176505d25c47e863aa65f681f77 SHA512 8f71a6f39bec08fab8401a7074d65fa9a4bdca66ed3c11f75777095f160e9eab25b75b21f1ea4e509f43ff0beebe777f690c13ad0325b5ee26bcd1ec301119e4
DIST jupyterlab-lsp-4.1.0.tar.gz 870899 BLAKE2B df1df3fc4dfc6cf268d2a81dcc63683e9b31595d633929b7788da21cfbc20f3da4c202e0d8fdcca3cfe033ed953e661bbaad605b783db8d5a26adc5ae169f2e4 SHA512 1510db853b75aeccc8dfbb9f466214c447fbdc8f885027c99ee7527c7759afa9774cfa682f3f66c6cce37767339b6e54338a7a14f6dc1d30b9944e1d1de8ff3c
+DIST jupyterlab-lsp-4.2.0.tar.gz 871193 BLAKE2B e3486f8e3dcdd534aa19209b936f6b2579c827a728fd080150fb6d31968bc1cd5b4c11b94e22e229eeaf6ac3953b473b89d66974d8f96bc9bc89fdf916d1c501 SHA512 4bd73f4d2e6a4823ad9649dcad4ac6e5de2626ef53fad13027de3a37cd6af5aa60dd707b93a599f41cdc4f7ea7b62a3ca473703f65e6a8038f8d7df62365aefe
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.2.0.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.2.0.ebuild
new file mode 100644
index 000000000000..f8fbb2f8f9b2
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="https://github.com/jupyter-lsp/jupyterlab-lsp"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-3.6.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+"