summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 16:17:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 16:43:41 +0100
commit3af180c9b57703b7dfebac8db7e4860aa4ad028e (patch)
treebde9bc7b01951eb45b4ec66a60019ee24cf14ca4 /dev-python/jupyter
parentdev-python/jsonref: Switch to PEP 517 build (diff)
downloadgentoo-3af180c9b57703b7dfebac8db7e4860aa4ad028e.tar.gz
gentoo-3af180c9b57703b7dfebac8db7e4860aa4ad028e.tar.bz2
gentoo-3af180c9b57703b7dfebac8db7e4860aa4ad028e.zip
dev-python/jupyter: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter')
-rw-r--r--dev-python/jupyter/jupyter-1.0.0-r4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jupyter/jupyter-1.0.0-r4.ebuild b/dev-python/jupyter/jupyter-1.0.0-r4.ebuild
new file mode 100644
index 000000000000..dff5487ba45c
--- /dev/null
+++ b/dev-python/jupyter/jupyter-1.0.0-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
+ "
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/jupyter_console[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]"
+PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+
+PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )