summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 11:37:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 11:37:58 +0200
commite79739b2d930a3ee31fc6a0cee0d54219a1e0a83 (patch)
treea62bdba2f2f2a779f6ca62b8ea806997634bc896 /dev-python/joblib
parentdev-python/sphinx-gallery: Remove old (diff)
downloadgentoo-e79739b2d930a3ee31fc6a0cee0d54219a1e0a83.tar.gz
gentoo-e79739b2d930a3ee31fc6a0cee0d54219a1e0a83.tar.bz2
gentoo-e79739b2d930a3ee31fc6a0cee0d54219a1e0a83.zip
dev-python/joblib: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/joblib')
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/joblib-1.4.0.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index 0ba7c6355cc4..0ea7d8f50d4b 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1,2 +1 @@
-DIST joblib-1.4.0.tar.gz 2115863 BLAKE2B cd61f3523ee697382db601ebb460aa6f4cd35947978fb07473c5e2e5337713a05aee8339acee211be0076d84a00174c37623cd6010b492aee84337abc2e5e633 SHA512 5c7e5475347906cdc8575eac8d2052470408c4ed5267d59a88a9d3126fb72b977d20b24fb0983b070e2f3c101e7da000fc03231733fef62531f9aeffacc47baf
DIST joblib-1.4.2.tar.gz 2116621 BLAKE2B e6c00a2308099690ddb89956b090996405d0b1c214e810b4c6ea4fe32bec8f297a324e6faa7c5f459c5ade84230d9b09e263b344069f43523208acf761d7b006 SHA512 d4c84803207ace0025701261f9e7976329e2ff9fa18a3155be1afe1f03ebfd470772e39e94b3ed01f9d1409589991c9592dc4188bca86dba158c44c70355441b
diff --git a/dev-python/joblib/joblib-1.4.0.ebuild b/dev-python/joblib/joblib-1.4.0.ebuild
deleted file mode 100644
index aa95f7bec3b5..000000000000
--- a/dev-python/joblib/joblib-1.4.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Tools to provide lightweight pipelining in Python"
-HOMEPAGE="
- https://joblib.readthedocs.io/en/latest/
- https://github.com/joblib/joblib/
- https://pypi.org/project/joblib/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/loky[${PYTHON_USEDEP}]
-"
-# joblib is imported by setup.py so we need ${RDEPEND}
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # https://github.com/joblib/joblib/issues/1115
- joblib/test/test_memory.py::test_parallel_call_cached_function_defined_in_jupyter
- # unexpectedly pickleable?
- joblib/test/test_hashing.py::test_hashing_pickling_error
- # https://github.com/joblib/joblib/issu
- joblib/test/test_parallel.py::test_main_thread_renamed_no_warning
-)
-
-python_prepare_all() {
- # unbundle
- rm -r joblib/externals || die
- sed -e "/joblib.externals/d" -i pyproject.toml || die
- find -name '*.py' -exec \
- sed -e 's:\(joblib\)\?\.externals\.::' \
- -e 's:from \.externals ::' \
- -i {} + || die
-
- distutils-r1_python_prepare_all
-}