summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-07 15:16:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-07 16:10:23 +0200
commit41a8177e283de661207acbd49f0d0409aa1c41c5 (patch)
treebe8c9443bf4473edd38bdb76fdca78912381dc58 /dev-python/jaraco-vcs
parentdev-python/pyyaml: Bump to 6.0.2 (diff)
downloadgentoo-41a8177e283de661207acbd49f0d0409aa1c41c5.tar.gz
gentoo-41a8177e283de661207acbd49f0d0409aa1c41c5.tar.bz2
gentoo-41a8177e283de661207acbd49f0d0409aa1c41c5.zip
dev-python/jaraco-vcs: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-vcs')
-rw-r--r--dev-python/jaraco-vcs/Manifest1
-rw-r--r--dev-python/jaraco-vcs/jaraco-vcs-2.4.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/jaraco-vcs/Manifest b/dev-python/jaraco-vcs/Manifest
index f43c05ac9cad..61fe3999b5e7 100644
--- a/dev-python/jaraco-vcs/Manifest
+++ b/dev-python/jaraco-vcs/Manifest
@@ -1,3 +1,4 @@
DIST jaraco_vcs-2.2.0.tar.gz 16660 BLAKE2B 9d48f78839e0e13aa5a520a167144deadce0d607c0bb378370d930d0aa1d94fe5778206384f29a449499e73b3cafc716358417d41f3016115b347d686e557269 SHA512 a842db1dac4beca4273b4a3afaec804bfc89286ad6eba6f9f47cd2b4dab7e04d9d12136bf555108fdbfe133fe62c71935be990b79cb0801766cc565c21343339
DIST jaraco_vcs-2.3.0.tar.gz 16855 BLAKE2B 993acc379515d51932311ff2009f85195198f1dd11da14ed07de98263e993a93d791275ddf6a29722ece03513109ece3e8bc1f84f884872723aaf4950629811f SHA512 08ba6792efc78088b49bd40f013f08d5cb8632a4cc649d81f89fcf76b802a012d3d5e6fc315fcc0862e35510b79461e1887efeb4f9cdfa2369ffb360ca849673
DIST jaraco_vcs-2.3.1.tar.gz 16957 BLAKE2B eeabf6b99d85a708ef3e5b012ea793e5f1923e0630ce3072b0e47d07401b4f98927397037438a167535ad510b37e106dc3dd6c19a76bd20373e8ef4533289054 SHA512 b6591fd17b4323c10d1e762b8efce71e127396a4922c148458ac12214feff62219511b92723c822807f4344b169a88f814fe15e23dcf14bc85f88926554d5822
+DIST jaraco_vcs-2.4.0.tar.gz 17233 BLAKE2B 5e97b2fb83fa19936c1fd04dcf50b5ca3cb8d91424c65094c61e30491ff72920482aa51edf6402998284b2df1cc7804db90c35b80c83d12f8be80f69e1a4661c SHA512 8be749129a4c40882ac82ea017f1e616dd7995a1185e858229650c38d13833c75b2c60f854ad004797934b2f49a4264096f7eb2580630b2b6f3b2f7a9706070a
diff --git a/dev-python/jaraco-vcs/jaraco-vcs-2.4.0.ebuild b/dev-python/jaraco-vcs/jaraco-vcs-2.4.0.ebuild
new file mode 100644
index 000000000000..b43fd6c3c6a3
--- /dev/null
+++ b/dev-python/jaraco-vcs/jaraco-vcs-2.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Facilities for working with VCS repositories"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.vcs/
+ https://pypi.org/project/jaraco.vcs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ dev-python/jaraco-versioning[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-home[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # assumes running inside the git repo
+ jaraco/vcs/__init__.py::jaraco.vcs
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p home -p jaraco.vcs.fixtures
+}