summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-22 21:22:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-22 21:24:44 +0100
commitb7509583942608616962c7e44de5e2d2374f15d9 (patch)
tree58acbcaa86c8c5f91a8eab6fe25a11212d8b7103 /dev-python/ipy
parentRename dev-python/{ipython_genutils → ipython-genutils} (diff)
downloadgentoo-b7509583942608616962c7e44de5e2d2374f15d9.tar.gz
gentoo-b7509583942608616962c7e44de5e2d2374f15d9.tar.bz2
gentoo-b7509583942608616962c7e44de5e2d2374f15d9.zip
Rename dev-python/{IPy → ipy}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/Manifest1
-rw-r--r--dev-python/ipy/ipy-1.01-r1.ebuild37
-rw-r--r--dev-python/ipy/metadata.xml13
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/ipy/Manifest b/dev-python/ipy/Manifest
new file mode 100644
index 000000000000..23bdf7c8ec7f
--- /dev/null
+++ b/dev-python/ipy/Manifest
@@ -0,0 +1 @@
+DIST IPy-1.01.tar.gz 33641 BLAKE2B 10d5ac5c3df00a562393ee762e9ad0f458ecf4745f894ab23e686b7112842adcbb3f25064c0010630745273fa72280ba5ef92a951d687d0f46f341acd6c041ad SHA512 f0983254523025a1819d543877d9651fb6a9e39dabd3b043488495f681b02e43b544a0121658a0430a418a1c39b360a59db1699af87a75a16a2bdc29fcb2b74c
diff --git a/dev-python/ipy/ipy-1.01-r1.ebuild b/dev-python/ipy/ipy-1.01-r1.ebuild
new file mode 100644
index 000000000000..31773ebcc797
--- /dev/null
+++ b/dev-python/ipy/ipy-1.01-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=IPy
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="
+ https://github.com/autocracy/python-ipy/
+ https://pypi.org/project/IPy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~mips ~ppc ~ppc64 ~sparc x86"
+IUSE="examples"
+
+python_test() {
+ "${EPYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ipy/metadata.xml b/dev-python/ipy/metadata.xml
new file mode 100644
index 000000000000..29540e39f370
--- /dev/null
+++ b/dev-python/ipy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">IPy</remote-id>
+ <remote-id type="github">autocracy/python-ipy</remote-id>
+ </upstream>
+</pkgmetadata>