summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-25 07:32:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-25 10:28:03 +0200
commit401f3462f7c712b1e0930982ee364a1135d98314 (patch)
treef97c5b1aa527c1a142ac403517c127fcf40abe93 /dev-python/identify
parentdev-python/colorama: Bump to 0.4.6 (diff)
downloadgentoo-401f3462f7c712b1e0930982ee364a1135d98314.tar.gz
gentoo-401f3462f7c712b1e0930982ee364a1135d98314.tar.bz2
gentoo-401f3462f7c712b1e0930982ee364a1135d98314.zip
dev-python/identify: Bump to 2.5.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.7.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 78ebda242ab7..79ae20eadd8c 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,2 +1,3 @@
DIST identify-2.5.5.gh.tar.gz 101461 BLAKE2B b3a4dc2273435cf9244af64b08b9a9a922025f7d32f479fb2641fcdd9f8a05d2778db126104b1e3b765b82af7ecc1660163de1f71098900296135cd1ccd129c5 SHA512 e02688805310a4f92d0435af562383a10297afa7fc468e44f73be40118c73e2ceac1b4ba7525c375fd0b671ea2700ba66307115c78558a370c525de8cba33c83
DIST identify-2.5.6.gh.tar.gz 101460 BLAKE2B c540934d4a482521758a64a1eb5e84b346eef0e0cccecbb9ad06e53e4b6872acb9c6fc94fccab9b75a7cf5658af78ad319d808a17f7ec44dfd08ae9c9a3b9f58 SHA512 9a35eb42767b0d2365b8da7c5aa5d7644272de5b65a505c5876cce0781222d8e52937b5c2d5594e560c5ab2fbbf4329555df15443b8f6110ac48880691af9089
+DIST identify-2.5.7.gh.tar.gz 101472 BLAKE2B 519f35e08258dac5ff4b897f4ee55cf432641e57c55ff1d05d3fdf564aa7eed441ba839f222b430eae96f55a8e6a5d14a9c25fc78b3536dad59c3604a3bff7c2 SHA512 186a0c36e3abadd4b2db1439daa837fed55db706c4eb1821d9ecf1288cd667706b708e1251f84d67a480cdd28e6a57960443b707c327e19a9342f5e2afdb1a7c
diff --git a/dev-python/identify/identify-2.5.7.ebuild b/dev-python/identify/identify-2.5.7.ebuild
new file mode 100644
index 000000000000..8ce2bd5b0e7d
--- /dev/null
+++ b/dev-python/identify/identify-2.5.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest