summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-17 07:48:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-17 08:26:08 +0200
commita83a30917204761a7d4f569a4967861b918a3009 (patch)
tree4c52d7c68dd8296a13befb70d44187f1d7611519 /dev-python/hypothesis
parentapp-emulation/wine-staging: add 8.6.1 (diff)
downloadgentoo-a83a30917204761a7d4f569a4967861b918a3009.tar.gz
gentoo-a83a30917204761a7d4f569a4967861b918a3009.tar.bz2
gentoo-a83a30917204761a7d4f569a4967861b918a3009.zip
dev-python/hypothesis: Bump to 6.72.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.72.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index be5547b08411..ecddc684586a 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-6.70.0.gh.tar.gz 9351669 BLAKE2B 04e6739a1e6cf5907486c5fc6e09d17
DIST hypothesis-6.70.1.gh.tar.gz 9351685 BLAKE2B 99488f4caae4da403ebe28c2c18829d493ea76515f4a503ece0063dad2638cc5d05f9b55372d5c457b0dfc3af31d3422c44d647ea0c2a92a83b20d64c70c4b2f SHA512 a858df7d469604b2d43d003c76f43e40931f6024f6cf164c9b427a449cd0d843df401052e3312c529fd4467d80e0870810ad6863812ec53a47dcf9ec82336472
DIST hypothesis-6.70.2.gh.tar.gz 9351849 BLAKE2B 074003592741cd89ae9ae44b3857daa3f5d1c8cbb0ab3513f3930b27fcc4e27417994c4240fbbba4649cb04716820db0e9c4f4ac745c194535a81b8a6197f7c3 SHA512 20f812ca8e005877893eacde1bac796495f8697ecbbd6da5f807a9ce6d7e310682030323a8b7bb3e646040253968d2f15cb6fcc858f47be631ef62af4924ac78
DIST hypothesis-6.71.0.gh.tar.gz 9357031 BLAKE2B e4a83a94bb6971c3ecba4cc69655f9da23a83ab48332a7a748ca7364d9e549a671bf466e32f6e65447f809a9917fc8fd2548dd26764173ea5849a4df3e027b54 SHA512 dea1d5ec1b753649345edd784183f171531adb583e33d0e5d12b14554169fa054e05f4c16135171c708c208b42968082b3ce79cc0441efccf1eff6da37c59f97
+DIST hypothesis-6.72.0.gh.tar.gz 9357320 BLAKE2B a688d3bfa90d4b335c022ed823e3ab3c9bb7b6e4404e62259e65faf7d2867d6cb8379b14a8328294c325506278c6523b9a14f6798110d67c9b636a89720a3ab9 SHA512 7d5cdf91114a34267edcca10295ee84005f2799ed58e7125c584fcc49171e60383a80c7a0040e41d24b3225113cb354966d40f61c94a28bcdbd596582577372b
diff --git a/dev-python/hypothesis/hypothesis-6.72.0.ebuild b/dev-python/hypothesis/hypothesis-6.72.0.ebuild
new file mode 100644
index 000000000000..ccd35ad36fe8
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.72.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}