summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 07:43:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 07:52:05 +0100
commit8b52538d61618d8c5eff7e39de2a7fbd817304b8 (patch)
tree22b851ca4211c59b1d5ea338b403ab65ad60d4fb /dev-python/hypothesis
parentdev-python/pytest-rerunfailures: Bump to 11.1 (diff)
downloadgentoo-8b52538d61618d8c5eff7e39de2a7fbd817304b8.tar.gz
gentoo-8b52538d61618d8c5eff7e39de2a7fbd817304b8.tar.bz2
gentoo-8b52538d61618d8c5eff7e39de2a7fbd817304b8.zip
dev-python/hypothesis: Bump to 6.68.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.68.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 8ea33655c8f4..bd1899da9b29 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -8,3 +8,4 @@ DIST hypothesis-6.66.0.gh.tar.gz 9349578 BLAKE2B 3dcdd9bcca00849d68a4bf136878409
DIST hypothesis-6.66.1.gh.tar.gz 9349822 BLAKE2B 728b6e1cb2a28a07cae066bb2e2f8099f21f9a27dbbcc27db1c4f97f6541f60464d90344630df75eb5cea9a65e865a296dbd8b5e20bcbbc17840c92d8f269ac7 SHA512 58ddb6c2bb77064d25ace1740bc5a9ba4d4b6c311da065aa065854c19d4920ec9d70b83935e1b9d057eb10c96c4fdfb445d17c6f321578cbde449df3c5edf704
DIST hypothesis-6.67.0.gh.tar.gz 9349921 BLAKE2B 03c2a16a1895ed45d9b902c378b6f5d55ef205999f7e69f4405a350b615e6dfccf225c76a193be412efa16d9e13a86a8f003955738e53f669578c01bca30ea9b SHA512 9ce51254d3285d859c877bd2a074fc837ea817f9eb8dcc6b4048d5af4650a958da66f5d46b7e68108a98fe0b4b6115fa2531adb43b94a4f38c8494c54b0e9a9d
DIST hypothesis-6.67.1.gh.tar.gz 9349899 BLAKE2B 279c0d6e1c690174ad5b2f2fa4c8eb42eb5f319d20b7fa362d8c69632ed05d54251e0a09a5025ef090df53d0660cfa3b4925b721ceadbad3cd59a64ea2ed882f SHA512 ea89f7cbd5bb1e5756a24da4996c3420f8eef5c7db543004d66d023bdcd05687c3d09d6b0a4213af42f449ea3c7c5140a96410cf94de15084a421c7cab95504e
+DIST hypothesis-6.68.0.gh.tar.gz 9350032 BLAKE2B c122455b7f941eaba8b37b7c4bd4760b2ea0d7c5cf3e973544b80edfa17ea13870c9c5121a121178850154f0058e55c4051ff0ea98d35d3c312468202108a04d SHA512 7ca3e79c1c5e091ae829244e1f6b3563c61add0a5bbe7a7b254df85191778a4b05a21f82ca3f50ba6e77a5ec5c9ec06d7dd15c6cf423c1a2eb524a2aeb3f2c91
diff --git a/dev-python/hypothesis/hypothesis-6.68.0.ebuild b/dev-python/hypothesis/hypothesis-6.68.0.ebuild
new file mode 100644
index 000000000000..c793a8a143d2
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.68.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}