summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-11 15:34:54 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-11 16:24:14 +0100
commit31d4daba6f12f25c1f35aac8f823479647c1b3be (patch)
tree33dfd5e7fbfaf51bbcb8fc60ff237087e05ca981 /dev-python/hypothesis
parentsys-kernel/pf-sources: add 6.7_p1 (diff)
downloadgentoo-31d4daba6f12f25c1f35aac8f823479647c1b3be.tar.gz
gentoo-31d4daba6f12f25c1f35aac8f823479647c1b3be.tar.bz2
gentoo-31d4daba6f12f25c1f35aac8f823479647c1b3be.zip
dev-python/hypothesis: Bump to 6.92.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.92.8.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 73e3806248cf..c8d2aa65307d 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-6.92.0.gh.tar.gz 9407699 BLAKE2B 7943aa958e135a954d4534b8992557a
DIST hypothesis-6.92.2.gh.tar.gz 9408586 BLAKE2B f6d873d16a337ceb5d78bc80622a08fb6856b5fdbd0c0c228bca13d340375b882416bf6ad4cfd08bb9959807ce1ac482ef5b4202792713c76a30dfff78fd4d4b SHA512 51bfd0b5d520fe84b4e682772888320d61bc4c52c6b4dda609f758336cc151bcf00714635e19230cdd1695209b6adf05cee349a82003e443dc5f52a7f105feb5
DIST hypothesis-6.92.6.gh.tar.gz 9410707 BLAKE2B 337369c5044682b3404ba0492cdab838db53e2c081e668e41facb6c8b6aaf38cf55f20a64150f1249360b64f90f34b42002becca6d7a33245a0ac55dd0e34e27 SHA512 86822dea75326343946aaf036aa8b0aee7287bdfbe501cf5c532e9377957bb6ba7f63595b1aae383bb007099e3ca33bd1f3d2ed6d7d8722ceb86b9146502a07e
DIST hypothesis-6.92.7.gh.tar.gz 9412316 BLAKE2B eae3a5d46dde5d69ab5fea429178eebeed06bec4ff25744324a3ed75e9433ac9652eb467a3a0a32fbbbe9924913f25ac87b375d1cf27c82fa5b024bdcbcdb791 SHA512 5fd04e49d76ec42dea4575666ed19ee249ef8cdcdca81d8c652b79fa879d51cfecd1851245c9b950627227d42c7520f7396816d2a8cc66991e1abc955a2c6cbd
+DIST hypothesis-6.92.8.gh.tar.gz 9412899 BLAKE2B 48bd1218f20260b983df4c75def1ad30a48d368975e5cf64bcc0eeb5148bd8cd2afe9b9b912304f13be791ca35f99bade225bcd7e600687a8249060b8b1767bf SHA512 ce5b97360dc45f4cbc26a7c68b1b7200e9906821200207479be80ab0c4bab5f5c363d1e914bc163eda096e575560146cdeb5f129b0ffd1545455df427c00cac2
diff --git a/dev-python/hypothesis/hypothesis-6.92.8.ebuild b/dev-python/hypothesis/hypothesis-6.92.8.ebuild
new file mode 100644
index 000000000000..f7f366381e4f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.92.8.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}