summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-19 01:58:24 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-19 02:02:03 -0400
commit327c6e76c9d3bc42f23f233d45c002dae31b4fa2 (patch)
tree803c1e45bb41d2aae0c4d518725ffc1d28053522 /dev-python/html5lib/html5lib-1.0.1.ebuild
parentapp-vim/vim-latex: remove old (diff)
downloadgentoo-327c6e76c9d3bc42f23f233d45c002dae31b4fa2.tar.gz
gentoo-327c6e76c9d3bc42f23f233d45c002dae31b4fa2.tar.bz2
gentoo-327c6e76c9d3bc42f23f233d45c002dae31b4fa2.zip
dev-python/html5lib: version bump to 1.0.1
Closes: https://bugs.gentoo.org/648186
Diffstat (limited to 'dev-python/html5lib/html5lib-1.0.1.ebuild')
-rw-r--r--dev-python/html5lib/html5lib-1.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/html5lib/html5lib-1.0.1.ebuild b/dev-python/html5lib/html5lib-1.0.1.ebuild
new file mode 100644
index 000000000000..1e9cddcf638b
--- /dev/null
+++ b/dev-python/html5lib/html5lib-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}