summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-04 07:01:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-04 07:13:12 +0200
commit24d82f706390864797d01c0eb2a782c164230519 (patch)
tree920e748d1b6e266a7c262168d24ad7a6a8315c57 /dev-python/hcloud
parentdev-python/pyproject-fmt: Bump to 2.1.4 (diff)
downloadgentoo-24d82f706390864797d01c0eb2a782c164230519.tar.gz
gentoo-24d82f706390864797d01c0eb2a782c164230519.tar.bz2
gentoo-24d82f706390864797d01c0eb2a782c164230519.zip
dev-python/hcloud: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hcloud')
-rw-r--r--dev-python/hcloud/Manifest1
-rw-r--r--dev-python/hcloud/hcloud-2.0.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index 3a1b5910da43..c2634f644083 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1 +1,2 @@
DIST hcloud-python-1.35.0.gh.tar.gz 114672 BLAKE2B 1742d571fccc369245d9bf9c8f85da1c37061a13368dfe928b666e4f514ed5bf9f87f61bc4e5859ec7a759f5dfa6364c60ff851572071b46b2df21c0fe6f02a6 SHA512 48cee279b4f0025c61662304e67b8cee6a718c071f801daac440054439dedb21ab656c244f486860b056edd8bdc9330d3134ec936085297f24442a93cbbcc9e4
+DIST hcloud-python-2.0.1.gh.tar.gz 117015 BLAKE2B e795ea4a114c8e2c71554f84646b574e94030c6e724456786a437cc58d3dd96118c274111bc3787d8e7074b81f0c2493b3c6c5b824f6a8acb6d3a70b4dd75d29 SHA512 2507687324579240d2ff89287a6bd8e90dd33bb1290514c925e7e786330032187fdf133af196a6c0529ecb7018003356e299fc00cbf5bf2819d1f8e229702a04
diff --git a/dev-python/hcloud/hcloud-2.0.1.ebuild b/dev-python/hcloud/hcloud-2.0.1.ebuild
new file mode 100644
index 000000000000..64eceb0a363c
--- /dev/null
+++ b/dev-python/hcloud/hcloud-2.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}