summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-20 07:23:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-20 07:38:30 +0200
commit2678a9ebce4c36d21ad0078354b4c3ea3f72429a (patch)
tree6a583bc17432561ad29903e98b7f852c090baa7c /dev-python/hcloud-python
parentdev-python/pluggy: Bump to 1.1.0 (diff)
downloadgentoo-2678a9ebce4c36d21ad0078354b4c3ea3f72429a.tar.gz
gentoo-2678a9ebce4c36d21ad0078354b4c3ea3f72429a.tar.bz2
gentoo-2678a9ebce4c36d21ad0078354b4c3ea3f72429a.zip
dev-python/hcloud-python: Bump to 1.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest1
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.21.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index c8bb583699c7..014321dd020f 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1 +1,2 @@
DIST hcloud-python-1.20.0.gh.tar.gz 100107 BLAKE2B 584e1399ddb1c5d1e5ad0beaf795609bb63d37457afe33c663cf303f8b20e2c6f6b3ff294007e9f4ae2d9aa833794e59516ad167f1dd51d14e692f6eab887881 SHA512 b17abc716ae6f7c78803096f2fd887e47ee746fccbe299cc434b7f445abdd7818e445d186f5adacc715971e2ebe2e92551cdb08aa1891ed58d8f443ea3be61fb
+DIST hcloud-python-1.21.0.gh.tar.gz 102150 BLAKE2B 4ec6fb813f61f3c487d632e12a71f9105af5d45a307567fd2b22ff716e30c645bffebc5cd768846fc7d7892ab753d3e4487a1b72edfee62fb99dfefe188be41d SHA512 8226a79324f0097d576cc1336e813a28a562fb9c3f50dcac1debb3c32bb52f4f5e563e920e2bbb6ce8be407a65de321b734d30156fd066d74ed95f6e6bd94a35
diff --git a/dev-python/hcloud-python/hcloud-python-1.21.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.21.0.ebuild
new file mode 100644
index 000000000000..1e4c87eaf1b4
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.21.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}