summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 09:14:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 09:40:47 +0200
commit84174dcad533cf0fd4aa22e17e43b40a5c43cdf2 (patch)
treecb34492f12e887180b91b54878ff871b1d91e5d8 /dev-python/hatch-fancy-pypi-readme
parentdev-python/google-auth: Bump to 2.11.1 (diff)
downloadgentoo-84174dcad533cf0fd4aa22e17e43b40a5c43cdf2.tar.gz
gentoo-84174dcad533cf0fd4aa22e17e43b40a5c43cdf2.tar.bz2
gentoo-84174dcad533cf0fd4aa22e17e43b40a5c43cdf2.zip
dev-python/hatch-fancy-pypi-readme: Bump to 22.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatch-fancy-pypi-readme')
-rw-r--r--dev-python/hatch-fancy-pypi-readme/Manifest1
-rw-r--r--dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.7.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/hatch-fancy-pypi-readme/Manifest b/dev-python/hatch-fancy-pypi-readme/Manifest
index 172765ae3b7b..bf73e6338d45 100644
--- a/dev-python/hatch-fancy-pypi-readme/Manifest
+++ b/dev-python/hatch-fancy-pypi-readme/Manifest
@@ -1 +1,2 @@
DIST hatch-fancy-pypi-readme-22.3.0.gh.tar.gz 22107 BLAKE2B 7358a35ed9176d5107d406c1f99cfcf17ce409224dcad55ac845087e2fd6cc9ab88e5ea929e3b1304bbff6464cbbbd0b0d9716bcfe199dcd887c809cd6a9356a SHA512 93fe293ddce6dde450bc427d8fa492cf2b1f7d4a0e2d754873f765f588a962ca2c7c48b515ba613503bed6100b302ed91bbedb4d6a9f8d7bc10ab4b1418164e8
+DIST hatch-fancy-pypi-readme-22.7.0.gh.tar.gz 25457 BLAKE2B 7426e6d8407b6b137524e651fdd4637980cdd781735c79df5172d3c9c45e5b7f07957e2591cc84c7eb750ac494770a68a8a7590dc7131eeb48c44bdb5a9995ac SHA512 4c6a02ac3774ee87f1cd725fae341739c3037aae772361e5664539fd0d8c09ba359245ddc925e028387a0359856979e35588d23824a66584a10f9fcac108b7d4
diff --git a/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.7.0.ebuild b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.7.0.ebuild
new file mode 100644
index 000000000000..f954065f6873
--- /dev/null
+++ b/dev-python/hatch-fancy-pypi-readme/hatch-fancy-pypi-readme-22.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fancy PyPI READMEs with Hatch"
+HOMEPAGE="
+ https://pypi.org/project/hatch-fancy-pypi-readme/
+ https://github.com/hynek/hatch-fancy-pypi-readme/
+"
+SRC_URI="
+ https://github.com/hynek/hatch-fancy-pypi-readme/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/hatchling[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fails without Internet (via pip)
+ tests/test_end_to_end.py
+)