summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-14 07:54:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-14 09:50:58 +0200
commitf38faa162d6b25028e38e71fc1015ca63eb71159 (patch)
tree95be50d88ff75149763a970bd195973d7dc06d07 /dev-python/gsd
parentdev-python/google-api-core: Bump to 2.1.1 (diff)
downloadgentoo-f38faa162d6b25028e38e71fc1015ca63eb71159.tar.gz
gentoo-f38faa162d6b25028e38e71fc1015ca63eb71159.tar.bz2
gentoo-f38faa162d6b25028e38e71fc1015ca63eb71159.zip
dev-python/gsd: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-2.5.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index 17518b905cdb..3215684416a9 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1,2 +1,3 @@
DIST gsd-v2.4.1.tar.gz 113343 BLAKE2B 5d87fe5dbac037aeccf2ef800fc18accb1888606ed904b15910480032edaaa21bed3adf264e17ea5dc42f6600321c838c15e73617a1d8f49fb9a8e5e79a0bff4 SHA512 47982500160dc2a125ae2d796fccb1fb31fa501f059c8dee9be1342713d62e3d6ce71b534dbc91daedbf6981299efa4b81382afa13283d647c0848bbd3591c91
DIST gsd-v2.4.2.tar.gz 111622 BLAKE2B a4e08cc03ced2158818cf35e3f827d819b2248de52a21060e06a8d47810e2cf80fc25c9033c8b231b58c723ae794b9066261fdfcc5d19713a916ec9aa31adddc SHA512 8db05903bfcfc45bf1ffc326ffe67ce4d980a2b91596256fa29d006c73f742ac69b829ea2f4b7e1508bf5279c584fd66316e2e0776236bdce791e2cb46093ed3
+DIST gsd-v2.5.0.tar.gz 105537 BLAKE2B dbd9cef142405bae4e99c180f6b7c65cb60240fe45e200643b8efd388c72830a70d97c649fdb686afeed4eb44386cbe68165ed105bd67424f1cbd3657159c16a SHA512 f5eda751bdfa4d3eae980029fe5594fc5698d68265784f089b0997441c18f58d70d71cf52a0b4fd208708aba0162164d1f640440964b6e211db856f10c7c0c67
diff --git a/dev-python/gsd/gsd-2.5.0.ebuild b/dev-python/gsd/gsd-2.5.0.ebuild
new file mode 100644
index 000000000000..c74dbc1734f1
--- /dev/null
+++ b/dev-python/gsd/gsd-2.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="https://github.com/glotzerlab/gsd"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND=${DEPEND}
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ epytest gsd/test
+}