summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-19 04:39:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-19 04:44:26 +0200
commitfd86d12aa56ed8f968eb39b43db70eba10330638 (patch)
tree124dfe6d04dbab111be729d8997266691f9a0071 /dev-python/griffe
parentdev-python/griffe: Remove old (diff)
downloadgentoo-fd86d12aa56ed8f968eb39b43db70eba10330638.tar.gz
gentoo-fd86d12aa56ed8f968eb39b43db70eba10330638.tar.bz2
gentoo-fd86d12aa56ed8f968eb39b43db70eba10330638.zip
dev-python/griffe: Bump to 0.43.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.43.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index 9cbccc3bde86..a18d27378877 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-0.42.2.gh.tar.gz 225772 BLAKE2B 43086f43a2e39ae71dfc76e34d99b7c66aa8092000367bb27a6da63a5568d4f89fd2d348266f657356555ca690b77429a0bf30c8eac48df17fa4bcba08dec1a1 SHA512 ca1a4847e4f96e2f8db0d617c378a1858c4f45b332a20aeea62ed9f6b1cfeca9c0f692472227e05f2576c52f777fd438ecacb888ea936a2e5dcf4b69088d8343
+DIST griffe-0.43.0.gh.tar.gz 226278 BLAKE2B c73edf303bb44ac714aca8b9516b332183d1b2d8465aabf3725ce3eabf44325660b05a183492535892cdd227065a41d4d8f808ddfb0204641b12495488bb3862 SHA512 34dbe13414d8f6df8a7fe486f542e195a235644c28b55717fe8abb7197780f51c05ff77a633f236cb09d5072a181fb5bac06e962db1d7d820fcd4316f5cdd471
diff --git a/dev-python/griffe/griffe-0.43.0.ebuild b/dev-python/griffe/griffe-0.43.0.ebuild
new file mode 100644
index 000000000000..73f99c53e1af
--- /dev/null
+++ b/dev-python/griffe/griffe-0.43.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)