summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2023-10-11 14:18:25 +0200
committerDavid Seifert <soap@gentoo.org>2023-10-11 14:18:25 +0200
commitf367e2ed289c475f83c608786f050060f6179d91 (patch)
tree48bedff66e6f661fb77f1d26a75273a47bdfa081 /dev-python/graph-tool
parentapp-emacs/treesit-auto: add 0.6.4 (diff)
downloadgentoo-f367e2ed289c475f83c608786f050060f6179d91.tar.gz
gentoo-f367e2ed289c475f83c608786f050060f6179d91.tar.bz2
gentoo-f367e2ed289c475f83c608786f050060f6179d91.zip
dev-python/graph-tool: version bump to 2.58
This also fixes the compilation with boost 1.83.0. Closes: https://github.com/gentoo/gentoo/pull/33261 Signed-off-by: Gerion Entrup <gerion.entrup@flump.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/graph-tool')
-rw-r--r--dev-python/graph-tool/Manifest1
-rw-r--r--dev-python/graph-tool/files/0001-Fix-compilation-with-boost-1.83-and-boost-1.76.patch28
-rw-r--r--dev-python/graph-tool/graph-tool-2.58.ebuild88
3 files changed, 117 insertions, 0 deletions
diff --git a/dev-python/graph-tool/Manifest b/dev-python/graph-tool/Manifest
index 7d305330310f..5f2bf4389bac 100644
--- a/dev-python/graph-tool/Manifest
+++ b/dev-python/graph-tool/Manifest
@@ -1 +1,2 @@
DIST graph-tool-2.57.tar.bz2 15192391 BLAKE2B bc124371dc4e60d95fb5ab7df8b79b785efe1684c3305bc1d15f17b120dbdda15c63e5996c8497ceaa89f77cfc38dcf90cb6c806d5bb3853a755be301a085f9a SHA512 48d0cf269abaa3124f69e3d67cad6e68db17953806a474905b450e0a203a95903ac17aaba4d7edfe6934e518fc9a6b1a894a6e99f72ea6fbffe5ad80b4efd77d
+DIST graph-tool-2.58.tar.bz2 15189499 BLAKE2B c3137df7e2c49bb453969f6355bda66090daaa993085ccffd0b055e6b6f55e5b7f13d851d860aaed08d961e47df360e88194cde6eced50a1d3e40701c9c823f2 SHA512 89d62c865ab7a2ade1fabf27fef3c74e7bc9fa85a25e3094941d9d7f1824dc2e426eae7a62660d57140c54bf6fefd07673ab9ec3a72ad05c63c84a7da9ba2ffa
diff --git a/dev-python/graph-tool/files/0001-Fix-compilation-with-boost-1.83-and-boost-1.76.patch b/dev-python/graph-tool/files/0001-Fix-compilation-with-boost-1.83-and-boost-1.76.patch
new file mode 100644
index 000000000000..bac83a8c0337
--- /dev/null
+++ b/dev-python/graph-tool/files/0001-Fix-compilation-with-boost-1.83-and-boost-1.76.patch
@@ -0,0 +1,28 @@
+From 005b377fa09c28a5f61f11319f337ceea640f4ab Mon Sep 17 00:00:00 2001
+From: Tiago de Paula Peixoto <tiago@skewed.de>
+Date: Fri, 1 Sep 2023 10:27:28 +0200
+Subject: [PATCH] Fix compilation with boost 1.83 and boost < 1.76 This unites
+ upstream commits: 0a837b40 and 5517e370.
+
+---
+ src/graph/gml.hh | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/graph/gml.hh b/src/graph/gml.hh
+index 7bea0ca3..b4cb84db 100644
+--- a/src/graph/gml.hh
++++ b/src/graph/gml.hh
+@@ -26,6 +26,10 @@
+ #include <boost/variant/get.hpp>
+ #include <boost/spirit/include/support_istream_iterator.hpp>
+
++#if BOOST_VERSION >= 107600
++#include <boost/regex/v5/unicode_iterator.hpp>
++#endif
++
+ #include <boost/algorithm/string/replace.hpp>
+
+ #include <boost/property_map/dynamic_property_map.hpp>
+--
+2.41.0
+
diff --git a/dev-python/graph-tool/graph-tool-2.58.ebuild b/dev-python/graph-tool/graph-tool-2.58.ebuild
new file mode 100644
index 000000000000..1856ccadd94d
--- /dev/null
+++ b/dev-python/graph-tool/graph-tool-2.58.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit check-reqs python-r1 toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://git.skewed.de/count0/graph-tool.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://downloads.skewed.de/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="An efficient python module for manipulation and statistical analysis of graphs"
+HOMEPAGE="https://graph-tool.skewed.de/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+cairo openmp"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/boost:=[context,python,${PYTHON_USEDEP}]
+ dev-libs/expat
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ sci-mathematics/cgal:=
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ cairo? (
+ dev-cpp/cairomm:0
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/cairo[X]
+ )"
+DEPEND="${RDEPEND}
+ dev-cpp/sparsehash"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/0001-Fix-compilation-with-boost-1.83-and-boost-1.76.patch # backport
+)
+
+# bug 453544
+CHECKREQS_DISK_BUILD="6G"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ my_configure() {
+ econf \
+ --disable-static \
+ $(use_enable openmp) \
+ $(use_enable cairo) \
+ --with-boost-python="boost_${EPYTHON/./}"
+ }
+ python_foreach_impl run_in_build_dir my_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir emake
+}
+
+src_install() {
+ my_python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir my_python_install
+
+ find "${ED}" -name '*.la' -delete || die
+}