summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-08 21:27:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-08 22:06:53 +0200
commitea09efa39d2758402117d919be5314e32103dee0 (patch)
treed9d795deb6da5e0b1717fec1e181922a3ebdb12d /dev-python/google-api-python-client
parentapp-admin/awscli: Bump to 1.29.22 (diff)
downloadgentoo-ea09efa39d2758402117d919be5314e32103dee0.tar.gz
gentoo-ea09efa39d2758402117d919be5314e32103dee0.tar.bz2
gentoo-ea09efa39d2758402117d919be5314e32103dee0.zip
dev-python/google-api-python-client: Bump to 2.96.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.96.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 9713eca24f3e..91d65f0dda0a 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google-api-python-client-2.93.0.tar.gz 10929939 BLAKE2B 67369eac89a12f212841923e2f912ce18b3ae39c7e0fafd45cbcbff3556919a784ec8dce2f73bcf91de3f2faa0404ec17719582a283120cf43d03a1513ed6c7c SHA512 41c6ef0cdf09e8c486b91490383bcb5914d8bd15a0ed486abcfe9b9121b035a2a9d9b8abeeb60ee0f6757e100618308df8967c6ace687d991ce9b609dd3b0747
DIST google-api-python-client-2.94.0.tar.gz 10987576 BLAKE2B 11851577d05e15208f4dc8905a8147b753442ceb36ebac74b01ecb8f7993bbc1d02813d12f06fea3ec0bec7df180da4a4963899bc85479ac0c744627a5aed614 SHA512 750d55848ebe69605d4948e368ddbb590b69f579d394e533bbc81a28d21b7435b817d08092f508303725cb492245cae8b9f7f94628593d10e9574cfe79440b4b
DIST google-api-python-client-2.95.0.tar.gz 11044697 BLAKE2B 1a28798146d2f321f0455dd092430cefb6d15ddc3469ba0b5ee2aab6546c4c56477379e970ac4b0eeb1a969d53a5ea002206145c046bbfa89c1b6d65dad5a2d1 SHA512 3e8419d4de8e1604365b47bc13ebb69939f2c86bc46e1e08277a3766a23f03660c25ab9113a13b6abbfee2afb4f49678144bb11c4a423c4cf05c83717863183e
+DIST google-api-python-client-2.96.0.tar.gz 11464696 BLAKE2B 5cec3b123ffe03f812909dd2f1aeb723ceacd657a5e3e796f358fde5c79fa274fb45a01a2857c9fbcb5431f00384792b1c3f721fafbf2c58e6732bb352539dc7 SHA512 94b59d38df431b1624192946f84229f100870c44eaa304f740dc1ff8973bf54f9c1bf59315aa826f122ec4b46c21507d4f2c5f691a18804e57d81379848346e8
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.96.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.96.0.ebuild
new file mode 100644
index 000000000000..0194f9640998
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.96.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}