summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 15:17:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 15:21:49 +0100
commit000713e41f155871ee38731d12a3625abb0190bd (patch)
tree18adb74b370930cd75f8e59f4c61a94edc3fbd55 /dev-python/google-api-python-client
parentapp-misc/gcalcli: Remove Python < 3.10 (diff)
downloadgentoo-000713e41f155871ee38731d12a3625abb0190bd.tar.gz
gentoo-000713e41f155871ee38731d12a3625abb0190bd.tar.bz2
gentoo-000713e41f155871ee38731d12a3625abb0190bd.zip
dev-python/google-api-python-client: Remove Python < 3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.68.0.ebuild4
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.70.0.ebuild4
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.71.0.ebuild53
3 files changed, 4 insertions, 57 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.68.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.68.0.ebuild
index 1c528a1a0c2d..dfe6a6ae8606 100644
--- a/dev-python/google-api-python-client/google-api-python-client-2.68.0.ebuild
+++ b/dev-python/google-api-python-client/google-api-python-client-2.68.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_10 )
inherit distutils-r1
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.70.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.70.0.ebuild
index 7e8aaa05d6d4..73c0eee57b5d 100644
--- a/dev-python/google-api-python-client/google-api-python-client-2.70.0.ebuild
+++ b/dev-python/google-api-python-client/google-api-python-client-2.70.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_10 )
inherit distutils-r1
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.71.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.71.0.ebuild
deleted file mode 100644
index 1b0a5fa95e96..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-2.71.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="
- https://github.com/googleapis/google-api-python-client/
- https://pypi.org/project/google-api-python-client/
-"
-SRC_URI="
- https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
- >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
- <dev-python/uritemplate-5[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # require Internet access (and credentials)
- tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
- tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
- )
-
- epytest tests
-}