summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-12 09:06:44 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-12 09:33:20 +0100
commit8022bde2790305427403d5871428dfe690084a6c (patch)
tree478b1d9e1e4d560ab9373ac7a8d0574e2f0f2a46 /dev-python/gmpy
parentdev-embedded/platformio: enable py3.10 (diff)
downloadgentoo-8022bde2790305427403d5871428dfe690084a6c.tar.gz
gentoo-8022bde2790305427403d5871428dfe690084a6c.tar.bz2
gentoo-8022bde2790305427403d5871428dfe690084a6c.zip
dev-python/gmpy: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gmpy')
-rw-r--r--dev-python/gmpy/Manifest1
-rw-r--r--dev-python/gmpy/gmpy-2.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/gmpy/Manifest b/dev-python/gmpy/Manifest
index 45c5011b8ffe..fe191b3c289a 100644
--- a/dev-python/gmpy/Manifest
+++ b/dev-python/gmpy/Manifest
@@ -1 +1,2 @@
+DIST gmpy2-2.1.0.tar.gz 258571 BLAKE2B 942786c9a2e1220ecad15e97c26cbea0b93c7719e5081f6defe7b71d43be0c4ce259355eb34fa013a0b90679022535a271f26425c615e65103d3a2705b27ec8e SHA512 0d62354a1446708548b8dfdc6d7f8000151eb5901251f87f935144f615fd586726617c7a2bd05b91dc3e2a0cfc8797cd81d60afb8c705da153b537345eaddb34
DIST gmpy2-2.1.0b5.tar.gz 264742 BLAKE2B 1dd6dc66f9ec8cb2738f449112aa44feb40ba983f6da5f7a0760016e79ffed19037d77d47c0c0b816f9088725207e50ba3bd423349ed4c744ff03059c4c6a19a SHA512 7dc647642d7b61af77258881a7b91ab967dd11a86ba88ff5b7fd41cd4c999d2bb4cfe586511e79cc5f21f0f00d0823bbd2620d69df051c8cead15090423a657a
diff --git a/dev-python/gmpy/gmpy-2.1.0.ebuild b/dev-python/gmpy/gmpy-2.1.0.ebuild
new file mode 100644
index 000000000000..ff00de624895
--- /dev/null
+++ b/dev-python/gmpy/gmpy-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+DESCRIPTION="Python bindings for GMP, MPC, MPFR and MPIR libraries"
+HOMEPAGE="https://github.com/aleaxit/gmpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-libs/mpc-1.0.2:=
+ >=dev-libs/mpfr-3.1.2:=
+ dev-libs/gmp:0=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # The tests program asks for input when running, disable that
+ "${FILESDIR}"/gmpy-2.1.0_beta5-test-input.patch
+)
+
+distutils_enable_sphinx docs
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
+}