summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-28 14:41:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-28 15:23:25 +0200
commit73535f2c2aa2ba94745b94c94f0c100c0f26fa6f (patch)
tree5c33a9ad889924bbde1630db2eba59652951e177 /dev-python/funcy/funcy-2.0.ebuild
parentdev-python/django-auth-ldap: Bump to 4.2.0 (diff)
downloadgentoo-73535f2c2aa2ba94745b94c94f0c100c0f26fa6f.tar.gz
gentoo-73535f2c2aa2ba94745b94c94f0c100c0f26fa6f.tar.bz2
gentoo-73535f2c2aa2ba94745b94c94f0c100c0f26fa6f.zip
dev-python/funcy: Bump to 2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/funcy/funcy-2.0.ebuild')
-rw-r--r--dev-python/funcy/funcy-2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/funcy/funcy-2.0.ebuild b/dev-python/funcy/funcy-2.0.ebuild
new file mode 100644
index 000000000000..1b6b33de12f1
--- /dev/null
+++ b/dev-python/funcy/funcy-2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A collection of fancy functional tools focused on practicality"
+HOMEPAGE="
+ https://github.com/Suor/funcy/
+ https://pypi.org/project/funcy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/whatever-0.7[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest