summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-14 10:28:27 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-14 14:26:12 +0200
commitd5d7eb2adee229c3698d600b3a40dc5eaf067fe9 (patch)
tree1c48904884c689ab580a0f7c4ce838cf1709c92d /dev-python/funcparserlib
parentdev-python/sphinxcontrib-spelling: Add python@ as maint (diff)
downloadgentoo-d5d7eb2adee229c3698d600b3a40dc5eaf067fe9.tar.gz
gentoo-d5d7eb2adee229c3698d600b3a40dc5eaf067fe9.tar.bz2
gentoo-d5d7eb2adee229c3698d600b3a40dc5eaf067fe9.zip
dev-python/funcparserlib: Bump to EAPI=7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/funcparserlib')
-rw-r--r--dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild b/dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..721fe2f08ec2
--- /dev/null
+++ b/dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Recursive descent parsing library based on functional combinators"
+HOMEPAGE="https://pypi.org/project/funcparserlib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local m=unittest
+ cd "${BUILD_DIR}"/lib || die
+ "${PYTHON}" -m ${m} discover || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( doc/*.md )
+ distutils-r1_python_install_all
+}