summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-05 10:20:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-05 10:20:20 +0200
commitcca032d24ac35cc0ae0c0a8fb3622fb8bac4aec6 (patch)
tree5fc0ac984cc84db7551073f4a2274ffe0baed61d /dev-python/fsspec
parentdev-python/pyglet: Remove old (diff)
downloadgentoo-cca032d24ac35cc0ae0c0a8fb3622fb8bac4aec6.tar.gz
gentoo-cca032d24ac35cc0ae0c0a8fb3622fb8bac4aec6.tar.bz2
gentoo-cca032d24ac35cc0ae0c0a8fb3622fb8bac4aec6.zip
dev-python/fsspec: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2023.1.0.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index feffd27a15eb..58931c2954cc 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,2 +1 @@
-DIST filesystem_spec-2023.1.0.gh.tar.gz 346962 BLAKE2B debabc938d2725b0c6e0a5aabdd6033a14655799a0b4ed98f171cdb3761dea6f3f85b63c91ca5461341e75c50aef53e4d09c6ac3582020247382c5e39a8d4791 SHA512 181e5dfc05ba664d9464246b2398c70a0bad3f274dab462a2432eae24ecf3307c49af46674f8222fac87964fbf3666bb7ad9e709484dc959b0333447b9a82a2b
DIST filesystem_spec-2023.3.0.gh.tar.gz 352352 BLAKE2B e4a4edb882aa0aa15f654d3ae63d278b03a0b1fdc99fb1e7f48baefa750134aa2c9ddc89cc53aa829155b103107cbfb0c99d6c6fdeb5bf85068af5f1fc467ae4 SHA512 7c21eb60932267fe73dea3672d2e9b2d71fb3df26aedec9d109109168b91605602903518337563c00ae8b7d82212211ca569d3a91adb840eefd41eecab33c3ec
diff --git a/dev-python/fsspec/fsspec-2023.1.0.ebuild b/dev-python/fsspec/fsspec-2023.1.0.ebuild
deleted file mode 100644
index 10b0b5f050b0..000000000000
--- a/dev-python/fsspec/fsspec-2023.1.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=filesystem_spec-${PV}
-DESCRIPTION="A specification that python filesystems should adhere to"
-HOMEPAGE="
- https://github.com/fsspec/filesystem_spec/
- https://pypi.org/project/fsspec/
-"
-SRC_URI="
- https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
-
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- distutils-r1_src_test
-}
-
-EPYTEST_DESELECT=(
- fsspec/tests/test_spec.py::test_find
- # requires s3fs
- fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
- fsspec/tests/test_core.py::test_mismatch
- # requires pyarrow, fastparquet
- fsspec/implementations/tests/test_reference.py::test_df_single
- fsspec/implementations/tests/test_reference.py::test_df_multi
- # bad test, fails when PWD contains dots...
- # https://github.com/fsspec/filesystem_spec/issues/1161
- fsspec/implementations/tests/test_local.py::test_make_path_posix
-)
-
-EPYTEST_IGNORE=(
- # sftp and smb require server started via docker
- fsspec/implementations/tests/test_dbfs.py
- fsspec/implementations/tests/test_sftp.py
- fsspec/implementations/tests/test_smb.py
- # unhappy about dev-python/fuse-python (?)
- fsspec/tests/test_fuse.py
-)