summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-09 16:25:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-09 16:36:04 +0200
commitfb60f097cca2f7ba00a4c3a9e1373c67baf8d103 (patch)
tree07b4e1b6c866e18a4f8b5a4c078d705f95c14b54 /dev-python/fritzconnection
parentdev-util/ostree: Version bump to 2023.5 (diff)
downloadgentoo-fb60f097cca2f7ba00a4c3a9e1373c67baf8d103.tar.gz
gentoo-fb60f097cca2f7ba00a4c3a9e1373c67baf8d103.tar.bz2
gentoo-fb60f097cca2f7ba00a4c3a9e1373c67baf8d103.zip
dev-python/fritzconnection: Bump to 1.12.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fritzconnection')
-rw-r--r--dev-python/fritzconnection/Manifest1
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.12.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index c7fdebe02360..ddd1824abbf5 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -1 +1,2 @@
DIST fritzconnection-1.12.0.gh.tar.gz 156938 BLAKE2B 731715514036a965fa8c9cf8bb808459f22a0c6b2df171c105f1d12f070eae8d6a36a0e77e9a35a024585f682b7c84f2a486006e670655a3b16b043695c57818 SHA512 b743810a24d39be34910e233faae0061974de540e746e88b2f63c1f3d5536e9de684862b02738f969e294ae2b6044d0994e1b9317e6a723b5acf9540d2995c12
+DIST fritzconnection-1.12.2.gh.tar.gz 157170 BLAKE2B 9d924ad3146361d9301f10154152cdf98987572880b79052bf9f2fa427fc8410bacae92e49219dd11372c2cce2d03fb0ffd4c732a45e210a05a0a561ba5fc155 SHA512 a9c62fdaa59f20e7661836888f49cadfc99d192c393f34d4cce59aa9b9a9eda162e25029933854e84de44e08190190f312bb3862d708e79d7cf1ee8496726eab
diff --git a/dev-python/fritzconnection/fritzconnection-1.12.2.ebuild b/dev-python/fritzconnection/fritzconnection-1.12.2.ebuild
new file mode 100644
index 000000000000..4f3353259b28
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.12.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="
+ https://github.com/kbr/fritzconnection/
+ https://pypi.org/project/fritzconnection/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-python/requests-2.22[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # flaky (relies on time.sleep(0.01) magically being sufficient)
+ fritzconnection/tests/test_fritzmonitor.py::test_terminate_thread_on_failed_reconnection
+)