summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-09-13 14:51:10 +0200
committerTiziano Müller <dev-zero@gentoo.org>2016-09-13 14:53:30 +0200
commit6a4fc569855379ec50fff9d928e75628545e915a (patch)
treea9d76dc329973d4204d4c383856ec8b23069fc07 /dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild
parentdev-python/flask-login: rev-bump for EAPI 6 bump, py-3.5 support and working ... (diff)
downloadgentoo-6a4fc569855379ec50fff9d928e75628545e915a.tar.gz
gentoo-6a4fc569855379ec50fff9d928e75628545e915a.tar.bz2
gentoo-6a4fc569855379ec50fff9d928e75628545e915a.zip
dev-python/flask-principal: rev-bump for EAPI 6 bump, py-3.5 support and working tests
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild')
-rw-r--r--dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild b/dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..5d5207a41004
--- /dev/null
+++ b/dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Identity management for flask"
+HOMEPAGE="http://pythonhosted.org/Flask-Principal/ https://pypi.python.org/pypi/Flask-Principal"
+SRC_URI="https://github.com/mattupstate/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# pypi tarball is missing tests
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}