summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-30 09:26:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 09:57:34 +0100
commitabe8a551344ad0fa4ee11e5b527825909b95fa10 (patch)
tree5e56f5de9af727457e2ab072744721eada7f934d /dev-python/flask-paginate
parentdev-vcs/gitg: Bump to v41 (diff)
downloadgentoo-abe8a551344ad0fa4ee11e5b527825909b95fa10.tar.gz
gentoo-abe8a551344ad0fa4ee11e5b527825909b95fa10.tar.bz2
gentoo-abe8a551344ad0fa4ee11e5b527825909b95fa10.zip
dev-python/flask-paginate: Bump to 2021.12.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index fd262aab4ce1..f8a8abdd5e85 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1 +1,2 @@
DIST flask-paginate-2021.10.26.tar.gz 120721 BLAKE2B dd37fa131baf20540620c350bca4a17f791df57c82fabd99e644891707259d330d4225fc666d3e5c31410bc17e10531bf735ab8a01e7129641fa81a9d8fbfe82 SHA512 86a782797a9401eecbbfc25c90834ed93d7c376c3eb6bc05f19edf7ad6f174aca01de9dc3b183c0c268e2995d81984fa1568e08aae8964e429c60f01b7b23736
+DIST flask-paginate-2021.12.28.tar.gz 120846 BLAKE2B 63c14a94db4c968ef22a84b28aee2ca3e223fa0a7a32e22644b02b718ae32ea9ece9177b85c66942165e01926b26bb599dd3ae47522ba9bbf9a1c68b7a5ce567 SHA512 3ff805ad2d30aadfd1affabde0b0caccf2c3c2efb54b0997f809e13a76c6db64082d0f003ba4485a824e48d5d2792d99bab5173059ebe5a4077a1aac99b3c4ca
diff --git a/dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild b/dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild
new file mode 100644
index 000000000000..49d2d8c73c6e
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}