summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-29 16:10:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-29 16:27:59 +0100
commit2b7eb1c2672021f902c41624a3fdc61ad10955ca (patch)
tree9d85a648966f5ab6a38cbd492e85841e66549376 /dev-python/flask-paginate
parentdev-python/lxml: Bump to 5.1.1 (diff)
downloadgentoo-2b7eb1c2672021f902c41624a3fdc61ad10955ca.tar.gz
gentoo-2b7eb1c2672021f902c41624a3fdc61ad10955ca.tar.bz2
gentoo-2b7eb1c2672021f902c41624a3fdc61ad10955ca.zip
dev-python/flask-paginate: Bump to 2024.3.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-2024.3.28.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index f384b23b80fb..9314730ab2c8 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1 +1,2 @@
DIST flask-paginate-2023.10.24.gh.tar.gz 121423 BLAKE2B 100cad03bb015fd5aba26faeaa1d9a62489b85cc0bf36176507af206bb01bdadae3c53802b53483d1482250ab4f0004c9800c61c8c210966b59b1339894d43d5 SHA512 9673698e394f9e11d56dec1a8a57310a963cd15f2fa4784d92e5a8af5d9fbe8e4b59bbd7e34e4e50a38c3ddc936222c19497ddcc233564c4a6aa61c83cd78efa
+DIST flask-paginate-2024.3.28.gh.tar.gz 121638 BLAKE2B 55fe7570a84e5cce0c2e071bf2c5ef2ad8271f69aef7f8ec6bf1bfcbc4608e0498570907c22e01aaf961a6b75e698261b1931521b886c7e2e891a3539c6c91a0 SHA512 31cb4aacdbfbb50c0aced5aeb46c5bbaf25ee2e323ab321f8b1cd8d258b8cef1aa07e30e3b2bd1673662de0aced1f7d5c914ce2b9dbb54072a71ca7a8019d99f
diff --git a/dev-python/flask-paginate/flask-paginate-2024.3.28.ebuild b/dev-python/flask-paginate/flask-paginate-2024.3.28.ebuild
new file mode 100644
index 000000000000..e76b6ec74b90
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2024.3.28.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="
+ https://flask-paginate.readthedocs.io/
+ https://github.com/lixxu/flask-paginate/
+ https://pypi.org/project/flask-paginate/
+"
+SRC_URI="
+ https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}