summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-08 22:48:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:40 -0500
commit92d0a1d8b7c03e413d50772ecd0f1a6ca24e0446 (patch)
treec201cd064c27bc4e12a678eceac701ff031d35ca /dev-python/fasteners
parentdev-python/msgpack: 0.6.1 bump (diff)
downloadgentoo-92d0a1d8b7c03e413d50772ecd0f1a6ca24e0446.tar.gz
gentoo-92d0a1d8b7c03e413d50772ecd0f1a6ca24e0446.tar.bz2
gentoo-92d0a1d8b7c03e413d50772ecd0f1a6ca24e0446.zip
dev-python/fasteners: 0.14.1-r1 adding py37
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/fasteners')
-rw-r--r--dev-python/fasteners/fasteners-0.14.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/fasteners/fasteners-0.14.1-r1.ebuild b/dev-python/fasteners/fasteners-0.14.1-r1.ebuild
new file mode 100644
index 000000000000..82e5591e2189
--- /dev/null
+++ b/dev-python/fasteners/fasteners-0.14.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package that provides useful locks"
+HOMEPAGE="https://github.com/harlowja/fasteners"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/monotonic-0.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -v || die
+}