summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-04 20:28:16 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-04 20:29:46 -0500
commitd420e6e0727cda67fef479a0d96bae010f4f100a (patch)
tree39f9db27a70417f438c8c0c0d9c0c2b237df5205 /dev-python/fabric
parentsys-kernel/gentoo-sources: Linux patch 5.4.2 (diff)
downloadgentoo-d420e6e0727cda67fef479a0d96bae010f4f100a.tar.gz
gentoo-d420e6e0727cda67fef479a0d96bae010f4f100a.tar.bz2
gentoo-d420e6e0727cda67fef479a0d96bae010f4f100a.zip
dev-python/fabric: drop py2.7 and other fixes
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/fabric')
-rw-r--r--dev-python/fabric/fabric-2.3.1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/fabric/fabric-2.3.1.ebuild b/dev-python/fabric/fabric-2.3.1.ebuild
index 8265a2381332..430bb1ca83dd 100644
--- a/dev-python/fabric/fabric-2.3.1.ebuild
+++ b/dev-python/fabric/fabric-2.3.1.ebuild
@@ -3,18 +3,20 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="A simple pythonic tool for remote execution and deployment"
-HOMEPAGE="https://www.fabfile.org https://pypi.org/project/Fabric/"
+HOMEPAGE="https://www.fabfile.org https://pypi.org/project/fabric/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc fab2"
+# Depends on pytest-relaxed which is not in tree
+RESTRICT="test"
RDEPEND="
!fab2? ( !dev-python/fabric:0 )
@@ -26,24 +28,21 @@ BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
dev-python/alabaster[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.4[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.7[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
)"
-# Depends on pytest-relaxed which is broken
-RESTRICT="test"
-
python_compile() {
if use fab2; then
export PACKAGE_AS_FABRIC2=1
- ln -s fabric fabric2 || die
+ ln -s fabric fabric2 || die "symlink create failed"
fi
distutils-r1_python_compile
}
python_compile_all() {
if use doc; then
- sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html || die
+ sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html \
+ || die "building docs failed"
fi
}