summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 12:15:46 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 12:15:46 +0100
commit9e38e52d3aa615d874be42d4fac17e3d098ae985 (patch)
tree20d0ab3bd44d17adce61a03c0fb6c42ade515536 /dev-python/elasticsearch
parentdev-python/cfn-lint: Remove old (diff)
downloadgentoo-9e38e52d3aa615d874be42d4fac17e3d098ae985.tar.gz
gentoo-9e38e52d3aa615d874be42d4fac17e3d098ae985.tar.bz2
gentoo-9e38e52d3aa615d874be42d4fac17e3d098ae985.zip
dev-python/elasticsearch: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elasticsearch')
-rw-r--r--dev-python/elasticsearch/Manifest2
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.10.0.ebuild66
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.10.1.ebuild68
3 files changed, 0 insertions, 136 deletions
diff --git a/dev-python/elasticsearch/Manifest b/dev-python/elasticsearch/Manifest
index 7ad2255bc415..eb1059cd1f9b 100644
--- a/dev-python/elasticsearch/Manifest
+++ b/dev-python/elasticsearch/Manifest
@@ -1,3 +1 @@
-DIST elasticsearch-py-8.10.0.gh.tar.gz 896444 BLAKE2B 7cadd9d23e31b42ba309345f228193a856ceac0c6b64786ae84668ff361f750d0413609b753b6faa113835eddb6b212b79bee0ee6e25025f2829b92b9109701d SHA512 2e72b726447f4fe139a7b1bb1a95e0eca613f53bb0c6d758b646203676835b56fedff418feca386d1300f8eb6ac2f14a5a99d7d7716bad286641ab43c9abcbc4
-DIST elasticsearch-py-8.10.1.gh.tar.gz 889458 BLAKE2B 4e47a76743c48e8c9e34a8169d99d85139f3c395c643080a039dfe5e64fa0059f485c155a56ebb4769f9632c2dd0db3f7583f3db0a62d7180967f0515caf4092 SHA512 9e212584b86959330c65e1cb00b0eec4afc4a8daed59c7e6a2b918dbfb4c872e025b5ef65c299da5ca74afb53ca9c1a4d628f6fce96c7140b85aff83c6a09ecf
DIST elasticsearch-py-8.11.0.gh.tar.gz 897889 BLAKE2B de1821f17c16198c8b85b863e06468715fb080b4e9354499bd4fc5c485dc81bb3747ee73bd5e26edcab71922d67699cbaba79b35a900b80020532bac805e5727 SHA512 914e909f5f2d6ee980d3cff981d1d605d9380211014381e9e998af46d52e0fc0568524c7c9e8d8fed710b855acdb15b1eeb0bcdb59607b67f2f8f99546a1bda8
diff --git a/dev-python/elasticsearch/elasticsearch-8.10.0.ebuild b/dev-python/elasticsearch/elasticsearch-8.10.0.ebuild
deleted file mode 100644
index 848d8945a95c..000000000000
--- a/dev-python/elasticsearch/elasticsearch-8.10.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1
-
-MY_P="elasticsearch-py-${PV}"
-
-DESCRIPTION="Official Elasticsearch client library for Python"
-HOMEPAGE="
- https://ela.st/es-python
- https://github.com/elastic/elasticsearch-py
- https://pypi.org/project/elasticsearch/
-"
-SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="Apache-2.0"
-SLOT="0/$(ver_cut 1)"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/aiohttp-3[${PYTHON_USEDEP}] <dev-python/aiohttp-4[${PYTHON_USEDEP}]
- >=dev-python/elastic-transport-8[${PYTHON_USEDEP}] <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4[${PYTHON_USEDEP}] <dev-python/requests-3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
- dev-python/unasync[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_IGNORE=(
- # REST api tests are a black hole for effort. It downloads the tests so its an ever moving target
- # It also requires effort to blacklist tests for apis which are license restricted.
- "test_elasticsearch/test_server/test_rest_api_spec.py"
- # Counting deprecation warnings from python is bound to fail even if all are fixed in this package
- # Not worth it
- "test_elasticsearch/test_client/test_deprecated_options.py"
- # Running daemon for tests is finicky and upstream CI fails at it as well
- "test_elasticsearch/test_server/"
- "test_elasticsearch/test_async/test_server/"
-)
-
-distutils_enable_sphinx docs/sphinx dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-src_prepare() {
- # Replace added pytest options with setting asyncio_mode to auto.
- # Test suite hasnt set asyncio parameters so its needed here.
- sed -i '/[tool:pytest]/,/^$/ { s/addopts.*/asyncio_mode = auto/ }' setup.cfg || die
-
- default
-}
diff --git a/dev-python/elasticsearch/elasticsearch-8.10.1.ebuild b/dev-python/elasticsearch/elasticsearch-8.10.1.ebuild
deleted file mode 100644
index 5d5ba19a26fa..000000000000
--- a/dev-python/elasticsearch/elasticsearch-8.10.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P="elasticsearch-py-${PV}"
-DESCRIPTION="Official Elasticsearch client library for Python"
-HOMEPAGE="
- https://ela.st/es-python
- https://github.com/elastic/elasticsearch-py/
- https://pypi.org/project/elasticsearch/
-"
-SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="Apache-2.0"
-SLOT="0/$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- <dev-python/aiohttp-4[${PYTHON_USEDEP}]
- >=dev-python/aiohttp-3[${PYTHON_USEDEP}]
- <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
- >=dev-python/elastic-transport-8[${PYTHON_USEDEP}]
- <dev-python/requests-3[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
- dev-python/unasync[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_IGNORE=(
- # REST api tests are a black hole for effort. It downloads the tests
- # so its an ever moving target. It also requires effort to blacklist
- # tests for apis which are license restricted.
- "test_elasticsearch/test_server/test_rest_api_spec.py"
- # Counting deprecation warnings from python is bound to fail even
- # if all are fixed in this package. Not worth it.
- "test_elasticsearch/test_client/test_deprecated_options.py"
- # Running daemon for tests is finicky and upstream CI fails at it
- # as well.
- "test_elasticsearch/test_server/"
- "test_elasticsearch/test_async/test_server/"
-)
-
-distutils_enable_sphinx docs/sphinx \
- dev-python/sphinx-autodoc-typehints \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o addopts= -p asyncio
-}