summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-10 18:47:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-10 19:28:13 +0200
commit39d13462f2f83343761feeb87f43ce752267424f (patch)
tree3212e5e7e637daf73e4e701c7d108ff8a4f0c247 /dev-python/editables
parentapp-text/pelican: add missing dependency; sync live; sort deps (diff)
downloadgentoo-39d13462f2f83343761feeb87f43ce752267424f.tar.gz
gentoo-39d13462f2f83343761feeb87f43ce752267424f.tar.bz2
gentoo-39d13462f2f83343761feeb87f43ce752267424f.zip
dev-python/editables: Bump to 0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/editables')
-rw-r--r--dev-python/editables/Manifest1
-rw-r--r--dev-python/editables/editables-0.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/editables/Manifest b/dev-python/editables/Manifest
index 638b7f405e29..c08afddb3914 100644
--- a/dev-python/editables/Manifest
+++ b/dev-python/editables/Manifest
@@ -1 +1,2 @@
DIST editables-0.2.gh.tar.gz 6488 BLAKE2B 02c3e0c352effa902306f5c5a7b6b96cae74c8d8f620dabb3fa4df2568c5d730ecf3a078bfdab8ef87bfa29cb95b24563587de361337a8617fa0776b890b35d2 SHA512 39adc72f9710c28853ffebc9c0757f779e948bed7fc32f78bf52bc26ef4a6a5b351bf011bbf9353fc68e6ef2506481927c3558f8fd6650d61ac7a09591566b74
+DIST editables-0.3.gh.tar.gz 12493 BLAKE2B 95e05e7553efa4856ee5bde2c18a2566f1e65318bfc46c8ecd732f4d6b42f10ce54cc3aecc4d53bcfc627e6938c4155d48a39ced5f64395dbafb9187cb009e4f SHA512 493f20d1e6b39f8ed6668adc208723d447a31ae3c3087f7db9a9a0de617958e8afebd3b3a1836638f749fb0ec911e51256b727deb4c0ce08327356238df0a3f3
diff --git a/dev-python/editables/editables-0.3.ebuild b/dev-python/editables/editables-0.3.ebuild
new file mode 100644
index 000000000000..d97361046581
--- /dev/null
+++ b/dev-python/editables/editables-0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for creating 'editable wheels'"
+HOMEPAGE="
+ https://pypi.org/project/editables/
+ https://github.com/pfmoore/editables/
+"
+SRC_URI="
+ https://github.com/pfmoore/editables/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~m68k ~ppc ~riscv ~s390 ~sparc"
+
+distutils_enable_tests pytest