summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-25 06:39:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-25 07:20:28 +0200
commit9504275bcd190f0bb4d13e909109fdb51c6d2a8e (patch)
tree295e876d763afee7f7c8c8354e45ea63039b17d2 /dev-python/editables/editables-0.5.ebuild
parentdev-python/pydantic-core: Bump to 2.4.0 (diff)
downloadgentoo-9504275bcd190f0bb4d13e909109fdb51c6d2a8e.tar.gz
gentoo-9504275bcd190f0bb4d13e909109fdb51c6d2a8e.tar.bz2
gentoo-9504275bcd190f0bb4d13e909109fdb51c6d2a8e.zip
dev-python/editables: Bump to 0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/editables/editables-0.5.ebuild')
-rw-r--r--dev-python/editables/editables-0.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/editables/editables-0.5.ebuild b/dev-python/editables/editables-0.5.ebuild
new file mode 100644
index 000000000000..8423d6038aee
--- /dev/null
+++ b/dev-python/editables/editables-0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for creating 'editable wheels'"
+HOMEPAGE="
+ https://pypi.org/project/editables/
+ https://github.com/pfmoore/editables/
+"
+SRC_URI="
+ https://github.com/pfmoore/editables/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest