summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-13 04:54:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-13 04:54:42 +0200
commit4bc67513780e1e7a284959f43d6b8e34bf9d7caa (patch)
treec0323c18015fe4e5fad78249e7ef2cc04c3f8a3c /dev-python/django-cors-headers
parentdev-python/bottleneck: Bump to 1.4.1_rc1 (diff)
downloadgentoo-4bc67513780e1e7a284959f43d6b8e34bf9d7caa.tar.gz
gentoo-4bc67513780e1e7a284959f43d6b8e34bf9d7caa.tar.bz2
gentoo-4bc67513780e1e7a284959f43d6b8e34bf9d7caa.zip
dev-python/django-cors-headers: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cors-headers')
-rw-r--r--dev-python/django-cors-headers/Manifest1
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-4.5.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index febb9963e194..231d9c2d991a 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1 +1,2 @@
DIST django-cors-headers-4.4.0.gh.tar.gz 31028 BLAKE2B 065ac5a96c3871e8dc0eff48ef54efeb57d60a2a1588b69345f116600fe31ce7b0532ff38ca554eb5a6cff338f10e557c8876486a10db158c24a6097c44d7288 SHA512 7a380512a62420d4b6b47d43fd5d5ced1579db61fc538b4b22665e14a71298a1b1f9ebe93f808245b756d18c494177ef9ecaa01ae8d86f90a2bbf9db9b1997d7
+DIST django-cors-headers-4.5.0.gh.tar.gz 31156 BLAKE2B 5f3c16c6524bdb5832579d9313863e8df334cfca4fbb2831c9cd813759e5f6b491c3967117bd04775dc42d01ef290f0fe5c36d708ee13b4c3076d4513988e91d SHA512 084a6809bfb8b15fe23b65c1cca52453c94a7f659174bb06c36dbc6ec925638bc4f8e2303d7b3e6ef1e0953815b5caf642a5ae988f8a65b18b278f28d59cd4d0
diff --git a/dev-python/django-cors-headers/django-cors-headers-4.5.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-4.5.0.ebuild
new file mode 100644
index 000000000000..cd44aca52d1b
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-4.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asgiref-3.6[${PYTHON_USEDEP}]
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest