summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-16 17:30:29 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-16 17:30:29 +0100
commitf4fd98828d4aac71851bc6918e9034e98063dd0c (patch)
tree441f8ae5672d5626d32fd850fbb30e9005670035 /dev-python/django-cacheops
parentdev-python/denonavr: Remove old (diff)
downloadgentoo-f4fd98828d4aac71851bc6918e9034e98063dd0c.tar.gz
gentoo-f4fd98828d4aac71851bc6918e9034e98063dd0c.tar.bz2
gentoo-f4fd98828d4aac71851bc6918e9034e98063dd0c.zip
dev-python/django-cacheops: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cacheops')
-rw-r--r--dev-python/django-cacheops/Manifest2
-rw-r--r--dev-python/django-cacheops/django-cacheops-6.1.ebuild72
-rw-r--r--dev-python/django-cacheops/django-cacheops-6.2.ebuild72
3 files changed, 0 insertions, 146 deletions
diff --git a/dev-python/django-cacheops/Manifest b/dev-python/django-cacheops/Manifest
index 6b493af5a502..a6d48b49ffcf 100644
--- a/dev-python/django-cacheops/Manifest
+++ b/dev-python/django-cacheops/Manifest
@@ -1,3 +1 @@
-DIST django-cacheops-6.1.gh.tar.gz 52972 BLAKE2B bdcd045912100ebdfdfd9add23b0df634b029cc2ffe41c351176e327f1e21c90457cfca9e45348dddce60e39fee5c431428ff7f2c954194e4c06c8bc09d78945 SHA512 43dcd4f302afee1acf73125aae7c2e2eece560cc6f07f3374391ac54e0438fd59b80a24e65f52bd7aa4978fd8a428939a8d607c7aa4b25f47d68373cfc12772f
-DIST django-cacheops-6.2.gh.tar.gz 55279 BLAKE2B 9fa05d6701e0cb705a012714f4ef5b98e6a56fe916033567e71256f2425ef844451d98cf7b2dd78023a680e19eab52b2f8cc4100ccf037e3d2e33f814eb47ead SHA512 48e51de2fd13c16a97085b9c6e61833f6c8b0252a0ede9e8a4beaa973e509fe34731804830b0d80926c0ae0f75aef939b7b21368de7ac17053bb1c10c0a7d104
DIST django-cacheops-7.0.gh.tar.gz 56009 BLAKE2B 7829c6308db163dce5e75170093107c5a9d7dc6c5caccdea55b81631f43664ddea767ce9320221abdfc9c52af6bea363a62b5e7e86e0afa54208fabf3baf431a SHA512 bae0005e377ab8d9f9dc6da50a845966affc75b57846eb432bd7090f20b644e1b7ce9e963a9b6e84270661c23a51c7cf0436fc8448d34fb3c2f3f3245f98f7f7
diff --git a/dev-python/django-cacheops/django-cacheops-6.1.ebuild b/dev-python/django-cacheops/django-cacheops-6.1.ebuild
deleted file mode 100644
index 8533afc768b7..000000000000
--- a/dev-python/django-cacheops/django-cacheops-6.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="ORM cache with automatic granular event-driven invalidation for Django"
-HOMEPAGE="
- https://github.com/Suor/django-cacheops/
- https://pypi.org/project/django-cacheops/
-"
-SRC_URI="
- https://github.com/Suor/django-cacheops/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-1.8[${PYTHON_USEDEP}]
- >=dev-python/redis-2.9.1[${PYTHON_USEDEP}]
- >=dev-python/funcy-1.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-db/redis
- dev-python/dill[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-src_prepare() {
- # Remove test dependent on unpackaged before_after
- sed -e 's/test_lock/_&/' -i tests/test_extras.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.settings
- local -x PYTHONPATH=.
- django-admin test -v 2 || die
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<-EOF || die
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/django-cacheops/django-cacheops-6.2.ebuild b/dev-python/django-cacheops/django-cacheops-6.2.ebuild
deleted file mode 100644
index 9e64deb2d434..000000000000
--- a/dev-python/django-cacheops/django-cacheops-6.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="ORM cache with automatic granular event-driven invalidation for Django"
-HOMEPAGE="
- https://github.com/Suor/django-cacheops/
- https://pypi.org/project/django-cacheops/
-"
-SRC_URI="
- https://github.com/Suor/django-cacheops/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-1.8[${PYTHON_USEDEP}]
- >=dev-python/redis-2.9.1[${PYTHON_USEDEP}]
- >=dev-python/funcy-1.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-db/redis
- dev-python/dill[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-src_prepare() {
- # Remove test dependent on unpackaged before_after
- sed -e 's/test_lock/_&/' -i tests/test_extras.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.settings
- local -x PYTHONPATH=.
- django-admin test -v 2 || die
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<-EOF || die
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}