summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-13 08:44:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-13 09:37:57 +0100
commitfeba3c195e829b8fba3d8bf942a59a8cc247796a (patch)
tree6db41c32258ada5ebc0f5601072ae3540b0572a1 /dev-python/defcon
parentdev-python/moto: Bump to 2.0.2 (diff)
downloadgentoo-feba3c195e829b8fba3d8bf942a59a8cc247796a.tar.gz
gentoo-feba3c195e829b8fba3d8bf942a59a8cc247796a.tar.bz2
gentoo-feba3c195e829b8fba3d8bf942a59a8cc247796a.zip
dev-python/defcon: Bump to 0.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/defcon')
-rw-r--r--dev-python/defcon/Manifest1
-rw-r--r--dev-python/defcon/defcon-0.8.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/defcon/Manifest b/dev-python/defcon/Manifest
index 59f51dcce74f..df920c800326 100644
--- a/dev-python/defcon/Manifest
+++ b/dev-python/defcon/Manifest
@@ -1,3 +1,4 @@
DIST defcon-0.6.0.tar.gz 403682 BLAKE2B c85cf4f846cab3f7543dcec885221e9f828cdf56fb1a373c9d06b27a29c1ab22fc9702d2ce561af97e3d4aa3b03712538ce0b29a0042fa4a0fea6f11eacba69b SHA512 b981c87d2355dc83b5da0ea4879707336ade8ea4d6ca2bc13da064367938579f2a60dfa5b1c0fd3629f4a2de97676e4f02f30f99a6116049cc2a10abd13a3d7b
DIST defcon-0.7.2.tar.gz 424146 BLAKE2B 6a3cc6c4bd8ccf030cda5fdaa3d7d2ba8aabc74daf71ce9a006de015d459ff0e5d876d584e7873fba7349a2941490db8d0ebd9a9c880e80db534b231639d3147 SHA512 9cf402b6626b75222e351d11afcde3e0c8be88b3ceb6ed4ff68cc3762b636905b61f31ece288f4d7e5273b6cd2b044661188a39fde1941e1bb5b483b23f3b42e
DIST defcon-0.8.0.tar.gz 424547 BLAKE2B 4018479d0d67603af58680c1150a143f92230c77b6fd6bda6741ed3f42403c7a7eb2ddc62632ffbf73096fffe8f089975b43a5bb88562ba059fa09ee2e0da12c SHA512 a7b0baec983a3051c7cd804b93983318c14f56a1a88f8f95699b0429740d7b3b27f6f6ab21fd1c31b542008b6f0924aae39e609fc4498ee64c0592272b536b8c
+DIST defcon-0.8.1.tar.gz 424712 BLAKE2B f2f2e3e811eeb163a875686dc6658376dfd9c09a8a9e3de2e6fdf512f25e93d5f6d8ac9ad3c31c70ecdcdd2c30b0e6a3d9b7a222bcd7065feba0b2e805e8eead SHA512 40606bd861fc7100d955e23ad6efb3879572179c81b730404afe41cef1e45ae5f54efb716af61866ac226ae057c6d85a123f4790442c085c054ff3cb5ec84108
diff --git a/dev-python/defcon/defcon-0.8.1.ebuild b/dev-python/defcon/defcon-0.8.1.ebuild
new file mode 100644
index 000000000000..a1f46cf8b2f5
--- /dev/null
+++ b/dev-python/defcon/defcon-0.8.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/robotools/defcon"
+SRC_URI="https://github.com/robotools/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/fonttools-3.31.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fs[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}