summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-11-22 09:48:12 -0600
committerAlex Brandt <alunduil@gentoo.org>2015-11-22 09:48:34 -0600
commitb30f00fe309701bedb3039e5459b16c14e59ed51 (patch)
treecc82b1745106d745a88729a7f1b8f60088e08b9f /dev-python/debtcollector
parentx11-misc/xdg-utils: Remove old (diff)
downloadgentoo-b30f00fe309701bedb3039e5459b16c14e59ed51.tar.gz
gentoo-b30f00fe309701bedb3039e5459b16c14e59ed51.tar.bz2
gentoo-b30f00fe309701bedb3039e5459b16c14e59ed51.zip
dev-python/debtcollector: add version 0.10.0
Package-Manager: portage-2.2.25
Diffstat (limited to 'dev-python/debtcollector')
-rw-r--r--dev-python/debtcollector/Manifest1
-rw-r--r--dev-python/debtcollector/debtcollector-0.10.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
index 63e4627c59c5..29fb55987b4d 100644
--- a/dev-python/debtcollector/Manifest
+++ b/dev-python/debtcollector/Manifest
@@ -1 +1,2 @@
+DIST debtcollector-0.10.0.tar.gz 20669 SHA256 8cc22cf2223af7789692ef0b1cb5c0c3a00da7d6e34cbfce125a956cb4d2f21e SHA512 a521a4dd5229384a500e973fa504be75c9019abd00cd4012118a566a1b4d95ecc10d616de29e0c16953a69fe7cdd219b44afb9463c59a6220c49d4a3dd12f896 WHIRLPOOL 2ffac565e27d411321a4c8c662e78bd0774158d9be0f77f8f7baa049fd62e52cd1b8a3a552f0f993e7e4c0b9325b0be3446580e602e4524e95f7d1e58361f388
DIST debtcollector-0.7.0.tar.gz 17151 SHA256 03ef06604e666a9f4a1506ffcfa887068bdb9f16e33657f9211a7b4e8bc753ea SHA512 684bea62b17843717c6aa19f36e538bd62bfe101693394eb66d6d6f408f32a0c9e458dee8c81324f4503fab952b73654f2eca24c51ef67594c51657fcdca9dad WHIRLPOOL 32cb704719ae3ea00f3d5e4e1df225604e226c5c4882afcf136fdfe035c367b334f1409c35b079214f8ab8b04608ef8a1f648a38632fc9fef9a8f312ce76d3c0
diff --git a/dev-python/debtcollector/debtcollector-0.10.0.ebuild b/dev-python/debtcollector/debtcollector-0.10.0.ebuild
new file mode 100644
index 000000000000..54ce16a07ca6
--- /dev/null
+++ b/dev-python/debtcollector/debtcollector-0.10.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="... Python deprecation patterns and strategies that collect technical debt ...."
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ !~dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}