summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-09 07:13:27 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-09 07:55:26 +0100
commit5062171fd895c882058141f950b503acd3d2e5fd (patch)
tree890d870e93c93af849734b3c5a5e28554bf79370 /dev-python/curtsies
parentdev-python/pykwalify: enable py3.11 (diff)
downloadgentoo-5062171fd895c882058141f950b503acd3d2e5fd.tar.gz
gentoo-5062171fd895c882058141f950b503acd3d2e5fd.tar.bz2
gentoo-5062171fd895c882058141f950b503acd3d2e5fd.zip
dev-python/curtsies: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/curtsies')
-rw-r--r--dev-python/curtsies/curtsies-0.4.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/curtsies/curtsies-0.4.1-r1.ebuild b/dev-python/curtsies/curtsies-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..feac078070d8
--- /dev/null
+++ b/dev-python/curtsies/curtsies-0.4.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Curses-like terminal wrapper, with colored strings"
+HOMEPAGE="
+ https://github.com/bpython/curtsies/
+ https://pypi.org/project/curtsies/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/blessed-1.5[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pyte[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest