summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-03 18:17:31 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-03 18:17:53 -0500
commit879e122bbc1922b173848dc681460c8ff1dbe5b6 (patch)
tree873ad9b0a356fb5b9245809ceb6afa56b1ac10a3 /dev-python/cssutils
parentdev-python/cssutils: amd64 stable (diff)
downloadgentoo-879e122bbc1922b173848dc681460c8ff1dbe5b6.tar.gz
gentoo-879e122bbc1922b173848dc681460c8ff1dbe5b6.tar.bz2
gentoo-879e122bbc1922b173848dc681460c8ff1dbe5b6.zip
dev-python/cssutils: fix QA issue with test RESTRICT
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/cssutils')
-rw-r--r--dev-python/cssutils/cssutils-1.0.1.ebuild2
-rw-r--r--dev-python/cssutils/cssutils-1.0.2-r1.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/cssutils/cssutils-1.0.1.ebuild b/dev-python/cssutils/cssutils-1.0.1.ebuild
index dbfd669743c4..dce1a69ac358 100644
--- a/dev-python/cssutils/cssutils-1.0.1.ebuild
+++ b/dev-python/cssutils/cssutils-1.0.1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_{5,6}} pypy )
inherit distutils-r1
@@ -14,6 +15,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 arm ppc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
diff --git a/dev-python/cssutils/cssutils-1.0.2-r1.ebuild b/dev-python/cssutils/cssutils-1.0.2-r1.ebuild
index 92fad59021ea..5f5efe08343f 100644
--- a/dev-python/cssutils/cssutils-1.0.2-r1.ebuild
+++ b/dev-python/cssutils/cssutils-1.0.2-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy )
inherit distutils-r1
@@ -14,6 +15,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~ppc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}