summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-18 13:38:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-18 13:40:03 +0200
commit5276093d36fdf47fa6ac4cfe17a5435995a6fe5d (patch)
tree4f41c2588dc300e5fbae7a704490f61ca4915136 /dev-python/cryptography
parentdev-python/QtPy: Fix missing pytest dep (diff)
downloadgentoo-5276093d36fdf47fa6ac4cfe17a5435995a6fe5d.tar.gz
gentoo-5276093d36fdf47fa6ac4cfe17a5435995a6fe5d.tar.bz2
gentoo-5276093d36fdf47fa6ac4cfe17a5435995a6fe5d.zip
dev-python/cryptography: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/Manifest2
-rw-r--r--dev-python/cryptography/cryptography-3.3.2.ebuild66
-rw-r--r--dev-python/cryptography/metadata.xml3
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index 46e9995bac7e..af5ed6c6b196 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -1,4 +1,2 @@
-DIST cryptography-3.3.2.tar.gz 539883 BLAKE2B e35de90362b24170c4025f67914e60c16fbf37fce6bcd5d6f3fe32e5a9bb60de8edbebcb1ff0450fabc9c244d4b1a4618c720b630f28c747fea17e9bf008f01f SHA512 55f6ee13342b3209b1fcb310f4c4d33d22856ee785cb2347e6ad36c34e9b42f6e0d5bece8e458b09663a5b78e34c4567fe7a211b51ca71f55ccc93e3f62dc5e4
DIST cryptography-3.4.7.tar.gz 546893 BLAKE2B 49bc1e098ed1ba0181059b645f6668cda6332d196eaca55270ebce6e07e5bb6ab6724c5050fde20e89b7025773960d74ec782bb875badbbd5dc9a04db0a536f1 SHA512 3c4cf64bc0b067ccdbb71efe04c32ac9d673faea6cc4ccd13d6b1b61920be4785806d19359b7657d032a2ff1c011a8b4f16ec4924d9df8a59d1a875a7f844473
-DIST cryptography_vectors-3.3.2.tar.gz 35168168 BLAKE2B 3991a16556ae5be0d153cfe302dd9a860918a80bd0bdef7104f3c170ba63941c4b1ff74750bc12329422a6061161cb6452bea60e191d85c0d79e0852566c6c0b SHA512 18590adb96a6f04b8a41d4346b126b8adfc854cbcec85f8c1c0a23b1b363f215b37da60ea94a481b8fd7752f07fba515b08fc18faf2e29fb858e133129971f7c
DIST cryptography_vectors-3.4.7.tar.gz 35168102 BLAKE2B fbefd3ff96548dde012fd290aba1c99d57db376023d486910e486cc9c143461ef1ae9b77824cc03307723d35142f0360bc961b548a4edc02357d3f1a0e7e4e9f SHA512 269b50fa4c5300da6758006d12be42f998630d23053ef9af0eb588fc9e6994b044d8822cff105e338f4d0d746ed0e204a4a9c42f54667e355e1ce86e6754bbe9
diff --git a/dev-python/cryptography/cryptography-3.3.2.ebuild b/dev-python/cryptography/cryptography-3.3.2.ebuild
deleted file mode 100644
index fd7468560e2d..000000000000
--- a/dev-python/cryptography/cryptography-3.3.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 multiprocessing
-
-VEC_P=cryptography_vectors-${PV}
-DESCRIPTION="Library providing cryptographic recipes and primitives"
-HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.org/project/cryptography/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- test? ( mirror://pypi/c/cryptography_vectors/${VEC_P}.tar.gz )"
-
-LICENSE="|| ( Apache-2.0 BSD )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="idna"
-
-RDEPEND="
- >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
- idna? ( >=dev-python/idna-2.1[${PYTHON_USEDEP}] )
- $(python_gen_cond_dep '
- >=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]
- ' 'python*')
- "
-BDEPEND="
- test? (
- >=dev-python/hypothesis-1.11.4[${PYTHON_USEDEP}]
- dev-python/iso8601[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-DEPEND="
- >=dev-libs/openssl-1.0.2o-r6:0=
- "
-RDEPEND+=${DEPEND}
-
-DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-
-src_prepare() {
- default
-
- # work around availability macros not supported in GCC (yet)
- if [[ ${CHOST} == *-darwin* ]] ; then
- local darwinok=0
- if [[ ${CHOST##*-darwin} -ge 16 ]] ; then
- darwinok=1
- fi
- sed -i -e 's/__builtin_available(macOS 10\.12, \*)/'"${darwinok}"'/' \
- src/_cffi_src/openssl/src/osrandom_engine.c || die
- fi
-}
-
-python_test() {
- local -x PYTHONPATH=${PYTHONPATH}:${WORKDIR}/${VEC_P}
- pytest -vv -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
- die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/cryptography/metadata.xml b/dev-python/cryptography/metadata.xml
index ff02c2b32ae2..2dfa57bc0fb6 100644
--- a/dev-python/cryptography/metadata.xml
+++ b/dev-python/cryptography/metadata.xml
@@ -5,9 +5,6 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
- <use>
- <flag name="idna">enable support for the old, deprecated IDNA specification (RFC 3490)</flag>
- </use>
<upstream>
<remote-id type="pypi">cryptography</remote-id>
<remote-id type="github">pyca/cryptography</remote-id>