summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 06:04:33 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 06:13:27 +0100
commit3b6bb4eab6a22597491ef3cd8ba52aa995f0c0af (patch)
tree39f7bfb8208c02d7c9d2b2e978d769c844e69734 /dev-python/croniter
parentdev-python/typed-ast: Bump to 1.5.1 (diff)
downloadgentoo-3b6bb4eab6a22597491ef3cd8ba52aa995f0c0af.tar.gz
gentoo-3b6bb4eab6a22597491ef3cd8ba52aa995f0c0af.tar.bz2
gentoo-3b6bb4eab6a22597491ef3cd8ba52aa995f0c0af.zip
dev-python/croniter: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/croniter')
-rw-r--r--dev-python/croniter/Manifest1
-rw-r--r--dev-python/croniter/croniter-1.1.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/croniter/Manifest b/dev-python/croniter/Manifest
index 41707847c079..da662033fd5d 100644
--- a/dev-python/croniter/Manifest
+++ b/dev-python/croniter/Manifest
@@ -1 +1,2 @@
DIST croniter-1.0.15.tar.gz 39164 BLAKE2B daf40bcc7c791dd2a65d2cd132c380dff03353ab6d7920adddff2b1b6a87166050be6ed2b7bac5eb2b9543dcab9a4f2f65738506dc35eff0836cc591e486f885 SHA512 5aebc8a60d278acae3cef7eee6ee0ec223e44ae01b69dae601f76cb14f135547557b1417498d71a84e187dd478605efdf15355f8ad0344e459b6b40d41e994af
+DIST croniter-1.1.0.tar.gz 39641 BLAKE2B 0c01d801b55b0fd6189d5b35f7493580aa25ea18e8be061152c6642fd05a9075c1211578124cd945bb754fda4704f637069a98c5080e41ce369cc3c959b35edf SHA512 ccc56e912d5ff684ec930f87ab096b0a739191014a2d0a76febddf0fe4155a6c319cf28011bea7b8f8034218a35813db65c3d4911ff575878a12f8fe1f75720e
diff --git a/dev-python/croniter/croniter-1.1.0.ebuild b/dev-python/croniter/croniter-1.1.0.ebuild
new file mode 100644
index 000000000000..87a9057da13a
--- /dev/null
+++ b/dev-python/croniter/croniter-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="https://github.com/kiorky/croniter https://pypi.org/project/croniter/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest