summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-17 04:48:44 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-17 04:48:44 +0200
commit0f4a76ac1ce0fbf06ac53acb1449d5ac92c82d63 (patch)
tree2692947bf47cbe4fc07d78d3b93dd79ddd973a4a /dev-python/crispy-bootstrap4
parentdev-python/hypothesis: Bump to 6.88.1 (diff)
downloadgentoo-0f4a76ac1ce0fbf06ac53acb1449d5ac92c82d63.tar.gz
gentoo-0f4a76ac1ce0fbf06ac53acb1449d5ac92c82d63.tar.bz2
gentoo-0f4a76ac1ce0fbf06ac53acb1449d5ac92c82d63.zip
dev-python/crispy-bootstrap4: Bump to 2023.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/crispy-bootstrap4')
-rw-r--r--dev-python/crispy-bootstrap4/Manifest1
-rw-r--r--dev-python/crispy-bootstrap4/crispy-bootstrap4-2023.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap4/Manifest b/dev-python/crispy-bootstrap4/Manifest
index 5c4459a71470..c8ca1b4b70f4 100644
--- a/dev-python/crispy-bootstrap4/Manifest
+++ b/dev-python/crispy-bootstrap4/Manifest
@@ -1 +1,2 @@
DIST crispy-bootstrap4-2022.1.gh.tar.gz 30814 BLAKE2B 573847b614b5f6cf71fea6ed6831eeef48ac01b2c2db07653d600b5b0829209188d235a143585ed4fabb663264aff3b5f7a416d99d12a8e268d4c62edaf3db84 SHA512 7f1e5443229274de2aaf28bd63507bbe5dff7923f27509801ea9de9246fa393bfc4563a4aa6d586a1e642b87bb7dddcb3ad3403653912c0197f8638141c42229
+DIST crispy-bootstrap4-2023.1.gh.tar.gz 31707 BLAKE2B 0a3c4c1b86ba9701365f1fcfb90811e1f6793fb9f374a510410c460bc62a48e06b72a75330f0efd3a06e51380f457eea66f236488774c3ee6bf758510136f08b SHA512 fbbc8c6e0f4351b50b0fa3a4d2faefb0775906c995f42cf9ccd9688d4780e05877a9a53f065ad92785d135a560064809f429dbcebe9f257f65f063d9539973e8
diff --git a/dev-python/crispy-bootstrap4/crispy-bootstrap4-2023.1.ebuild b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2023.1.ebuild
new file mode 100644
index 000000000000..91cf18b22f0e
--- /dev/null
+++ b/dev-python/crispy-bootstrap4/crispy-bootstrap4-2023.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap4 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/
+ https://pypi.org/project/crispy-bootstrap4/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap4/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-crispy-forms-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest