summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 03:46:29 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 03:46:29 +0200
commitdff3a36945568a2c8698682a243325daff7beb85 (patch)
tree990a9d38c3a03e80999b6cc7aa1bfff60025aeea /dev-python/coverage
parentdev-python/trimesh: Bump to 4.4.3 (diff)
downloadgentoo-dff3a36945568a2c8698682a243325daff7beb85.tar.gz
gentoo-dff3a36945568a2c8698682a243325daff7beb85.tar.bz2
gentoo-dff3a36945568a2c8698682a243325daff7beb85.zip
dev-python/coverage: Bump to 7.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-7.6.0.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index fc0f68b92bc8..a10fe5969e2c 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,2 +1,3 @@
DIST coverage-7.5.3.tar.gz 786184 BLAKE2B 014a21273bf302a7e10d3239edda1a95b99674abd0b7b769a688a4e576d0b9e5ce9189ee38e8c53b0cbd5ea7bd2c7f7583704455f6842c9a19e77cc19aae3de1 SHA512 6c72525b19b0efbf6a23b8a2860e056613c8119a5306978a67bc11b8598bac693e7541a9ca206bb9394511c9a84097a7f450ebf38e7c1c40e914fd71cf7546ce
DIST coverage-7.5.4.tar.gz 793238 BLAKE2B a53967307ce9cbb72d89810575574a7a1358c988e5e02cfa2a982ba8e68e7efd477c2d902c2037c67f18309c54777f3422db845b7753da49ccb69855289c13de SHA512 363658864f9a5116e49bd10a45a8ceeb0bb62c70458e0c0ce7ae90f3ddea0659d67af1a35a44a47e673b256cdad8ea0963339110dabfd7031d6b98ba483f3606
+DIST coverage-7.6.0.tar.gz 797590 BLAKE2B c63f022de8ace0e0ee420ecd12431104cafb9471272afd9ecb5ac0a356f065372955097c30c1128547da828ae7e20c8ea615db0fcc31c2ddb61d5377d7c284f7 SHA512 ed27f19a17d4f231a7d28af23045fb0144a8c192cc9b31f90353f558a99a9c4159d7fab6bb5c1231aa8229b8fd56e1163cc0880c4edb3d802e6d48af062468e9
diff --git a/dev-python/coverage/coverage-7.6.0.ebuild b/dev-python/coverage/coverage-7.6.0.ebuild
new file mode 100644
index 000000000000..17b43f197092
--- /dev/null
+++ b/dev-python/coverage/coverage-7.6.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="
+ https://coverage.readthedocs.io/en/latest/
+ https://github.com/nedbat/coveragepy/
+ https://pypi.org/project/coverage/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/s:-q -n auto::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+test_tracer() {
+ local -x COVERAGE_CORE=${1}
+ einfo " Testing with the ${COVERAGE_CORE} core ..."
+ epytest -p flaky -p hypothesis -p xdist tests
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: fails because of additional "Terminated" print on SIGTERM
+ tests/test_concurrency.py::SigtermTest::test_sigterm_threading_saves_data
+ # broken because of pytest plugins explicity loaded
+ tests/test_debug.py::ShortStackTest::test_short_stack{,_skip}
+ # these expect specific availability of C extension matching
+ # COVERAGE_CORE (which breaks testing pytracer on CPython)
+ tests/test_cmdline.py::CmdLineStdoutTest::test_version
+ tests/test_debug.py::DebugTraceTest::test_debug_sys_ctracer
+ )
+ local EPYTEST_IGNORE=(
+ # pip these days insists on fetching build deps from Internet
+ tests/test_venv.py
+ )
+
+ "${EPYTHON}" igor.py zip_mods || die
+
+ local -x COVERAGE_TESTING=True
+ # TODO: figure out why they can't be imported inside test env
+ local -x COVERAGE_NO_CONTRACTS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" coverage/ || die
+ test_tracer ctrace
+ fi
+
+ test_tracer pytrace
+
+ case ${EPYTHON} in
+ python3.1[01]|pypy3)
+ ;;
+ *)
+ # available since Python 3.12
+ test_tracer sysmon
+ ;;
+ esac
+
+ if [[ -n ${c_ext} ]]; then
+ rm coverage/*.so || die
+ fi
+}